Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 861 Skopiuj do schowka Szukanie, sprawdzanie, podstawianie
Autor Wiadomość
mnily
[Usunięty]

Wysłany: 03-04-2007, 15:22   Szukanie, sprawdzanie, podstawianie

Hej,
Mam znowu broblem dla mnie nie rozwiązywalny, ale dla Was to pewnie bułka z masełkiem :)
Otóż:
W jednym zeszycie (zeszyt1) mam 300 arkuszy z danymi ludzi i w arkuszu 301 zestawienie wszystkicz danych z popdzednich arkuszy.

I teraz tak, muszę zrobić nowy taki zeszyt (zeszyt2) z identycznym rozkładem komórek, i żeby po wpisaniu do odpowiednich pól imienia i nazwiska i zatwierdzeniu enterem excel sprawdził czy ten delikwent występuje w "zeszyt1". No i teraz nie wiem czy lepiej przeszukać konkretne adresy dwóch komórek (imie, nazwisko) w arkuszach od 1 do 300 czy przeszukać arkusz301 gdzie dane osób są ułożone w wierczach. (imię w komórce Bn, nazwisko Cn, gdzie n =<1-300>)
I jeśli ten ktoś jest w bazie to niech w komórce A1 w "zeszyt2" bedzie napis "Występuje" lub "nie występuje" i tam gdzie będzie "występuje" to żeby wstawiało dane w dalsze komórki typu ulica, kod, poczta itd. (również nie wiem czy z konkretnego adresu komórki arkuszy 1-300 czy z tego zestawienia odpowiednio komórki Dn, En ... )
Tak żeby uzupełniać tylko brakujące.

Jeśli nie jasno lub za mało treściwie napisalem to prosze powiedzieć to postaram się bardziej rzeczowo.

Z góry dzieki!
ID posta: 4439 Skopiuj do schowka
 
 
Trebor 
Excel Expert


Pomógł: 1752 razy
Posty: 4680
Wysłany: 03-04-2007, 21:02   

Formuła dla imienia i nazwiska
Kod:

=JEŻELI(SUMA.ILOCZYNÓW(([Zeszyt1]zestawienie!B1:B18="nazwisko")*([Zeszyt1]zestawienie!C1:C18="imię")*WIERSZ([Zeszyt1]zestawienie!C1:C18))>0;"występuje";"niestety")


dla wyciągnięcia danych z pozostałych kolumn np.
Kod:

=JEŻELI(SUMA.ILOCZYNÓW(([Zeszyt1]zestawienie!B1:B18="nazwisko")*([Zeszyt1]zestawienie!C1:C18="imię")*WIERSZ([Zeszyt1]zestawienie!C1:C18))>0;ADR.POŚR("[Zeszyt1]zestawienie!D"&SUMA.ILOCZYNÓW(([Zeszyt1]zestawienie!B1:B18="nazwisko")*([Zeszyt1]zestawienie!C1:C18="imię")*WIERSZ([Zeszyt1]zestawienie!C1:C18)));"")


Pozdrawiam
_________________
Trebbor@wp.pl
ID posta: 4453 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.wip.pl

Archiwum

Strona uĹźywa plikĂłw cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przegl�darce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
SprawdĹş, w jaki sposĂłb przetwarzamy dane osobowe