Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 73317 Skopiuj do schowka Wskaż najbliższą i najdalszą datę dla zadania
Autor Wiadomość
wiorek
Exceloholic


Posty: 106
Wysłany: 02-09-2022, 21:00   Wskaż najbliższą i najdalszą datę dla zadania

Hej,

W załączniku podsyłam plik. Próbowałem z warunkami ale głupoty wyszły. Problem polega na
tym, że posiadam kolumnę z taskami/użytkownikami. Obok stworzona jest tabela z datami, pod każdą datą jest rozpoczęcie i zakończenie tasku. Potrzebuję aby w kolumnie tak jak w załączniku, pokazane było rozpoczęcie i zakończenie projektu.


Z góry dziękuje za pomoc :beer

dataoddo.xlsx
Pobierz Plik ściągnięto 27 raz(y) 9.48 KB

ID posta: 420259 Skopiuj do schowka
 
 
Marecki 
Excel Expert



Wersja: Win Office 2019
Pomógł: 2585 razy
Posty: 8602
Wysłany: 02-09-2022, 21:45   

Dla G2
Kod:
=JEŻELI(LUB(G$1=$B2;ORAZ(G$1<=$C2;G$1>=$B2));$A2;"")
kopia w prawo i w dół.
_________________
Hardware - ta część komputera, którą można kopnąć kiedy software przestanie funkcjonować.

Szkolenia z Excela , FB
Office 2019 Professional Plus , Windows 11 x64
Pozdrawiam, były mkkk23 teraz Marecki.
ID posta: 420260 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 969 razy
Posty: 5280

Wysłany: 03-09-2022, 09:03   

VBA:
Kod:
Option Explicit

Private Sub CommandButton1_Click()
Dim i&, j&, d1&, d2&
Dim pocz, kon

d1 = Cells(Rows.Count, "A").End(xlUp).Row
d2 = Cells(1, Columns.Count).End(xlToLeft).Column

Range(Cells(2, 7), Cells(d1, d2)).ClearContents

For i = 2 To d1
    pocz = Cells(i, 2).Value
    kon = Cells(i, 3).Value
    For j = 7 To d2
        If Cells(1, j).Value = pocz Then Cells(i, j).Value = Cells(i, 1).Value
        If Cells(1, j).Value = kon Then Cells(i, j).Value = Cells(i, 1).Value
    Next j
Next i

End Sub


Kopia dataoddo-1.xlsm
Pobierz Plik ściągnięto 8 raz(y) 21.5 KB

_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
Chcesz precyzyjną odpowiedź - zadaj precyzyjne pytanie.
ID posta: 420270 Skopiuj do schowka
 
 
Bill Szysz 
Excel Expert


Wersja: Win Office 365
Pomógł: 1004 razy
Posty: 3923
Wysłany: 03-09-2022, 09:52   

Troszke inaczej niż Marecki
Kod:
=JEŻELI(MEDIANA($C2;$B2;G$1)=G$1;$A2;"")

oczywiście kopia w prawo i w dół
_________________
Zlecenia, konsultacje, doradztwo i szkolenia z Power Query, Power BI i Excela - Raporty, Analizy, Projekty
Pozdrawiam, były szbill62 aktualnie Bill Szysz
ID posta: 420273 Skopiuj do schowka
 
 
wiorek
Exceloholic


Posty: 106
Wysłany: 05-09-2022, 10:21   

Dziękuje, plusy poleciały ale chyba źle się wyraźiłem.
W zakresie G2:Q5 - mam tabelę w której są wpisane osoby / zadania
W kolumnie A1:A5 - mam wpisane te same osoby / zadania
W zakresie B2:C5 chciałbym wpisać formułę / vba, która pokaże mi rozpoczęcie i zakończenie projektu z tabeli. W Pierwszym pliku zaznaczyłem kolorami, które dane chciałbym aby były wzięte.
Jeżeli np.

Mam wpisane 08.09-10.09 - osoba Basia
to w B3 chciałbym mieć 08.09 natomiast w C3 10.09, bez środkowego dnia tylko skrajne.

Aktualnie w tabeli mogę wypełnić to co mam w zakresie A:C, natomiast przy planowaniu na pół roku/ rok, wolałbym mieć na odwrót :)
ID posta: 420293 Skopiuj do schowka
 
 
Bill Szysz 
Excel Expert


Wersja: Win Office 365
Pomógł: 1004 razy
Posty: 3923
Wysłany: 05-09-2022, 10:43   

Faktycznie zupełnie się nie zrozumieliśmy.
Teraz rozumiem, że masz to co w kolumnach G:Q a chcesz uzyskac to co kolumnach B i C.
Dla B2
Kod:
=INDEKS($G$1:$AZ$1;PODAJ.POZYCJĘ(A2;G2:AZ2;0))

a w C2
Kod:
=WYSZUKAJ("ZZZZZ";G2:AZ2;$G$1:$AZ$1)

Oczywiście kopia w dół.

Zakres dałem szerszy (do AZ) - dostosuj sobie wg potrzeb

dataoddo_BS.xlsx
Pobierz Plik ściągnięto 8 raz(y) 9.9 KB

_________________
Zlecenia, konsultacje, doradztwo i szkolenia z Power Query, Power BI i Excela - Raporty, Analizy, Projekty
Pozdrawiam, były szbill62 aktualnie Bill Szysz
ID posta: 420295 Skopiuj do schowka
 
 
wiorek
Exceloholic


Posty: 106
Wysłany: 05-09-2022, 10:59   

Bill Szysz napisał/a:
Faktycznie zupełnie się nie zrozumieliśmy.
Teraz rozumiem, że masz to co w kolumnach G:Q a chcesz uzyskac to co kolumnach B i C.
Dla B2
Kod:
=INDEKS($G$1:$AZ$1;PODAJ.POZYCJĘ(A2;G2:AZ2;0))

a w C2
Kod:
=WYSZUKAJ("ZZZZZ";G2:AZ2;$G$1:$AZ$1)

Oczywiście kopia w dół.

Zakres dałem szerszy (do AZ) - dostosuj sobie wg potrzeb


O to chodziło, dziękuje
ID posta: 420296 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.wip.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe