Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Przesunięty przez: Eltokar
09-06-2008, 08:37
Sprawdzenie zadania.
Autor Wiadomość
mahomet
[Usunięty]

Wysłany: 05-11-2007, 19:46   Sprawdzenie zadania.

1. Losowane są 2 liczby z przedziału <1,49>, zaokraglone do liczb całkowitych.
Jeżeli suma tych liczb jest wieksza od 50 i podzielna prze 5 gracz wygrywa, natomiast gdy suma jest mniejsza od 20 i nieparzysta gracz przegrywa.

Losowanie 2 liczb komórka A1 i A2:
Kod:
=ZAOKR(LOS()*(48)+1;0)

Funkcja
Kod:
=JEŻELI(ORAZ(A1+A2>50;(A1+A2)/5;(A1+A2)<20);"wygrana";"przegrana")

Czy jest to prawidłowo zrobione i jak okreslić czy liczba jest parzysta czy nie?,
ID posta: 19188 Skopiuj do schowka
 
 
zubel 
ExcelSpec



Pomógł: 333 razy
Posty: 566
Wysłany: 05-11-2007, 20:14   

tylko nie wiadomo co jest pomiędzy sumą większą od 20 i mniejszą od 50
nazwałem to "nie wiadomo"
Kod:

=JEŻELI(ORAZ(A1+B1>50;MOD((A1+B1);5)=0);"wygrana";JEŻELI(ORAZ(A1+B1<20;MOD(A1+B1;2)<>0);"przegrana";"nie wiadomo"))
_________________
zubel
ID posta: 19190 Skopiuj do schowka
 
 
Bartek 
ExcelSpec



Pomógł: 69 razy
Posty: 105
Wysłany: 06-11-2007, 12:44   Re: Sprawdzenie zadania.

Witaj,

Formułę wygranej podał Ci zubel, ale zwróce jeszcze uwagę na samo losowanie liczb:

mahomet napisał/a:
1. Losowane są 2 liczby z przedziału <1,49>, zaokraglone do liczb całkowitych.Losowanie 2 liczb komórka A1 i A2: (...)
=ZAOKR(LOS()*(48)+1;0)


Ta formuła nie jest do końca dobra, bo nie da rozkładu równomiernego (1 i 49 będą pojawiały się rzadzej niż inne liczby, a chyba nie taki był cel). Powinno być raczej:

=ZAOKR.DÓŁ(LOS()*(49)+1;0)
_________________
Sto gier w Excelu i nie tylko... 8-)
ID posta: 19222 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.wip.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe