Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Przesunięty przez: Eltokar
09-06-2008, 08:30
Średnia, modalna, medialna z liczb losowych
Autor Wiadomość
konfu
[Usunięty]

Wysłany: 09-10-2007, 09:17   Średnia, modalna, medialna z liczb losowych

Mam taki problem muszę wykonac nast. zadanie:

wygenerować 10.000 losowych liczb z przedziału <-x,x>

No i ma to działac w nast. sposób:

wpisuję liczbę x i wyświetla mi się 10tys. losowych liczb z przedziału <-x,x>

a następnie musze policzyć:

srednią, modalną, medialną

z tych liczb

PLZ HELP ME :hamer :hamer :hamer Dzisiaj mielismy 1sza lekcje z excela i dowalil takie zadanie :/ :/ ://
ID posta: 17257 Skopiuj do schowka
 
 
Eltokar 
ExcelSpec


Pomógł: 175 razy
Posty: 313
Wysłany: 09-10-2007, 09:29   

w A1 wpisz:
=ZAOKR($B$1*(LOS()*2-1);0)
i przeciągnij na 10000 wierszy
(zakładam liczby całkowite)

w b1 będziessz sobie wpisywał x

w b2 średnia:
=ŚREDNIA(A1:A10000)
w b3 mediana:
=MEDIANA(A1:A1000)
w b4 modalna:
=WYST.NAJCZĘŚCIEJ(A1:A10000)
ID posta: 17260 Skopiuj do schowka
 
 
konfu
[Usunięty]

Wysłany: 09-10-2007, 09:41   

dzieki wielkie

[ Dodano: 2007-10-09, 10:45 ]
Jeszcze jedno jak mam zrobic żeby zamiast cyfr były litery - teraz zadanie dodatkowe ^^

Z tym że literki nie moga być na minusie :(
ID posta: 17263 Skopiuj do schowka
 
 
toxic 
ExcelSpec


Pomogła: 139 razy
Posty: 356
Wysłany: 09-10-2007, 09:53   

Może po prostu
Kod:
=ZNAK(wyliczona zaokrąglona wartość)
ID posta: 17264 Skopiuj do schowka
 
 
Eltokar 
ExcelSpec


Pomógł: 175 razy
Posty: 313
Wysłany: 09-10-2007, 10:59   

Nie wiem, czy do końca rozumiem o Ci idzie ale jeśli chcesz mieć literę zamiast cyfry to
użyj funkcji podstaw()
np:
PODSTAW(a1;1;"A")
podstawi za każdą 1kę w liczbie literę "A"
czyli wartość 123112 zamieni na A23AA2 (oczywiście wynikiem jest już tekst)
Można to zagnieździć (ale tylko do 7 razy) więc:
w c1 dopisz
Kod:
=PODSTAW(PODSTAW(PODSTAW(PODSTAW(PODSTAW(PODSTAW(PODSTAW(PODSTAW(A1;8;"H");7;"G");6;"F");5;"E");4;"D");3;"C");2;"B");1;"A")
w d1:
Kod:
=PODSTAW(PODSTAW(C1;0;"J");9;"I")

i przeciągnij w dół.

Formułami nic nie innego przychodzi mi do głowy.

Możesz też w edytorze VBA (Narzędzia -> makro -> edytor Microsoft...)
utworzyć moduł z makrem (Insert -> module)
i tam wkleić kod:
Kod:
Public Function podmien(tekst As Variant) As String
Dim i As Integer
Dim odp As String
odp = ""
For i = 1 To Len(CStr(tekst))
Select Case Mid(tekst, i, 1)
Case "0"
odp = odp & "J"
Case "1"
odp = odp & "A"
Case "2"
odp = odp & "B"
Case "3"
odp = odp & "C"
Case "4"
odp = odp & "D"
Case "5"
odp = odp & "E"
Case "6"
odp = odp & "F"
Case "7"
odp = odp & "G"
Case "8"
odp = odp & "H"
Case "9"
odp = odp & "I"
Case Else
odp = odp & Mid(tekst, i, 1)
End Select
Next i
podmien = odp
End Function


teraz w arkuszu w e1 użyj funkcji podmien(a1)
i przeciągnij w dół.

Ale generalnie jeśli to na pierwsze zajęcia z excela to proponuję zostać przy formułach
ID posta: 17276 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.wip.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe