Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64060 Skopiuj do schowka Makro wyszukujące błędy w planowaniu
Autor Wiadomość
jaky
Starszy Forumowicz



Posty: 31
Wysłany: 07-02-2019, 08:36   Makro wyszukujące błędy w planowaniu

Witam,

Potrzebuję makra, które wyszuka błędy w planowaniu w zaznaczonym obszarze arkusza.
Tym błędem jest brak odpoczynku pracownika wynoszącym co najmniej 11 godz. pomiędzy godz. zakończenia pracy, a godz. rozpoczęcia pracy w dniu następnym.

Ponieważ dane zaciągane są z innego źródła, nie mogę posiłkować się formułą. Dane wprowadzane są kolejno dzień po dniu, więc najlepiej byłoby, gdyby informacja o błędzie ukazała się od razu albo w formie komunikatu, albo zaznaczając komórki (np. w kolorze czerwonym), które nie spełniają założenia.

W załączniku znajduje się przykładowy plik.
Od razu zaznaczam, że moje wiedza na temat makr jest żadna :)

Przykład.xlsx
Pobierz Plik ściągnięto 8 raz(y) 11.56 KB

ID posta: 362114 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 1141 razy
Posty: 3443
Wysłany: 07-02-2019, 10:30   

To temat z działu "Zadania" - nie masz żadnego makra ;-)
ID posta: 362118 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1212 razy
Posty: 4186
Wysłany: 07-02-2019, 10:40   

Skoro "wiedza na temat makr jest żadna" to formuła.

Wybierz B5:AF6000 (zmień 6000 na max spodziewanych wierszy) -> FW -> "use a formula ..." -> formuła
Kod:

=JEŻELI($A5="godz. zak.";JEŻELI(ORAZ(B5<>"";C6<>"";C6<>"W");MOD(C6-B5;1)<11/24);JEŻELI($A5="godz. rozp.";ORAZ(B5<>"";A4<>"";MOD(B5-A4;1)<11/24)))

-> Format -> wybierz kolor -> OK -> OK -> OK
ID posta: 362119 Skopiuj do schowka
 
 
jaky
Starszy Forumowicz



Posty: 31
Wysłany: 07-02-2019, 11:46   

Obaj Panowie macie rację :)

Formatowanie jest skuteczne.

Pozdrawiam
ID posta: 362123 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe