Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Przesunięty przez: Kaper
24-03-2021, 09:32
Problem z formułą WYSZUKAJ.PIONOWO w Arkuszach Google
Autor Wiadomość
Profek208
Świeżak


Wersja: Win Office 365
Posty: 3
Wysłany: 18-03-2021, 10:57   Problem z formułą WYSZUKAJ.PIONOWO w Arkuszach Google

Witam,

mam problem z rozpisaniem formuły WYSZUKAJ.PIONOWO w Arkuszach Google.
Posiadam dwa pliki. W pliku nr 1 w poszczególnych arkuszach znajdują się firmy. W każdej z nich są dane takie jak paszport pracownika oraz data zakończenia pracy. W pliku nr 2 posiadam arkusz "Pobrane dane", w którym za pomocą funkcji QUERY i IMPORTRANGE pobieram sobie wszystkie numery paszporów oraz daty zakończeń z firm z pliku nr 1. W pliku nr 2 znajduje się również arkusz o nazwie "Arkusz testowy". Tam docelowo będzie się znajdować lista osób. Chciałabym, aby na podstawie numeru paszportu automatycznie uzupełniało mi tam daty w kolumnach S i U, tj. "PRACA DO". Kolumna S odpowiada za pierwszy okres, w którym pracownik pracował. Może być sytuacja, że zaczyna pracować drugi raz, stąd kolumna U o takiej nazwie, i właśnie w niej powinna się znajdować druga data zakończenia pracy. Dotychczas posiadam następujące formuły w tych kolumnach: w kolumnie S:
Kod:
=INDEKS('Pobrane dane'!$B$1:$B$6710;MIN.K(JEŻELI('Pobrane dane'!$A$1:$A$6710=$H2;WIERSZ('Pobrane dane'!$A$1:$A$6710);"");1))

oraz w kolumnie U:
Kod:
=JEŻELI.BŁĄD(INDEKS('Pobrane dane'!$B$1:$B$6710;MIN.K(JEŻELI('Pobrane dane'!$A$1:$A$6710=$H2;WIERSZ('Pobrane dane'!$A$1:$A$6710);"");2));"")
.

Jednak zauważyłam, że pojawia się problem w momencie, gdy dana osoba zmieniała sobie firmę. Czyli pracowała np. w firmie nr 1, a póżniej w formie nr 2 i za jakiś czas znowu wróciła do firmy nr 1. Potrzebuję rozwiązania, które pozwoli na to, aby możliwa była weryfikacja, że dana data zakończenia z arkusza "Pobrane dane" dotyczy konkretnej firmy.

W załączniku znajdują się te pliki, o których mowa.

Plik 2.xlsx
Pobierz Plik ściągnięto 6 raz(y) 7.69 KB

Plik 1.xlsx
Pobierz Plik ściągnięto 6 raz(y) 30.62 KB

ID posta: 402316 Skopiuj do schowka
 
 
Kaper 



Zaproszone osoby: 2
Wersja: Win Office 365
Pomógł: 4226 razy
Posty: 7955
Wysłany: 24-03-2021, 09:35   

Dwie sprawy porządkowe:
- publikuj pytania we właściwych działach. Porządek znakomicie ułatwia korzystanie z forum. Temat przenioslem do działu o Google Sheets
- stosuj się do wymagań http://www.excelforum.pl/regulamin.htm Np. formuły i makra umieszczaj w znacznikach CODE, bo to bardzo poprawia czytelność. Tym razem poprawiam w Twoim poście bez konsekwencji (taryfa ulgowa dla "świeżaka" :-D ).
_________________
Kaper Jej Królewskiej Mości :boss

Jeśli dane będą torturowane dość długo, przyznają się do wszystkiego
ID posta: 402657 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe