Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Przesunięty przez: bodek
30-08-2019, 08:55
Google Excel - zliczanie godzin
Autor Wiadomość
grzeniosg 
forumowicz


Posty: 15
  Wysłany: 18-07-2017, 13:22   Google Excel - zliczanie godzin

Witam,

Potrzebuje pomocy w formułach do prawidłowego liczenia godzin:
1. pierwszej formule utworzyłem zakres z którego mają być obliczane godziny wraz z innymi możliwościami(L4,UW itd) - tu brakuje mi aby nie zliczało godzin, jeśli są one po innej stawce (wiersz 3).
Kod:
=COUNTIF(F5:ABU5;1)+COUNTIF(F5:ABU5;"UW")+COUNTIF(F5:ABU5;"O")+COUNTIF(F5:ABU5;"NŻ")+COUNTIF(F5:ABU5;"L4")


2. kolumna D ma za zadanie zliczać tylko określone godziny 23-7
Kod:
VLOOKUP("23","0","1","2","3","4","5","6";2:2;(F5:ABT5))

zaczałem coś kombinować ale nie wychodzi mi..


3.kolumna E ma za zadanie sprawdzać wiersz 3 i jeśli pracownik jest w tej godzinie i jest w wierszu TAK to zlicząc tylko te godziny gdzie jest TAK.

Link do arkusza:CIACH

edycja zbiniek:
Załącz plik na forum (zgodnie z pkt. 2.4 Regulaminu naszego forum); na naszym forum plik ma szansę być dłużej niż na wielu innych serwerach. Część osób ma ograniczony w pracy dostęp do takich serwerów. Często jeśli nie jesteśmy zarejestrowanym użytkownikiem, to trzeba czekać na możliwość ściągnięcia i jeszcze inne (np. wyskakujące okienka). Dostępne formaty załączników znajdziesz w Regulaminie.


godziny.xlsx
Pobierz Plik ściągnięto 162 raz(y) 585.97 KB

ID posta: 326348 Skopiuj do schowka
 
 
kuma 
Excel Expert


Wersja: Win Office 2010
Pomógł: 1374 razy
Posty: 3957
Wysłany: 18-07-2017, 14:56   

Witaj. Dla pktu 1 i 3. Pkt 2 jest bardzo niejasny. Wpisz 8h w dowolny dzień i teraz bądź mądry i pisz wiersze: czy te 8h są na I zm, II, czy III?
Dla pktu 1 formuła w 'C5' i kopia w dół
Kod:
=SUMA.ILOCZYNÓW((F5:IK5={1;"UW";"NŻ";"L4";"O"})*($F$3:$IK$3<>"TAK"))
Dla pktu 3 w 'E5' i kopia w dół
Kod:
=SUMA.ILOCZYNÓW((F5:IK5={1;"UW";"NŻ";"L4";"O"})*($F$3:$IK$3="TAK"))
Pozdrawiam.
ID posta: 326372 Skopiuj do schowka
 
 
grzeniosg 
forumowicz


Posty: 15
Wysłany: 18-07-2017, 15:55   

Dzięki o to mi chodziło.

Co do pkt 2:
wiersz 2 oznacza godziny od północy(0:XX) do godziny 23:XX i w momencie kiedy pracownik ma wstawioną "1" w tych godzinach od (23:XX-6:XX) to wtedy zwracamy w kolumnie D liczbę godzin nocnych.
ID posta: 326385 Skopiuj do schowka
 
 
kuma 
Excel Expert


Wersja: Win Office 2010
Pomógł: 1374 razy
Posty: 3957
Wysłany: 18-07-2017, 17:10   

Jeśli w wierszu 2 nie są liczby to w 'D5'
Kod:
=SUMA.ILOCZYNÓW(($F$2:$IK$2={"0";"1";"2";"3";"4";"5";"6";"23"})*(F5:IK5=1))
Pozdrawiam.
ID posta: 326387 Skopiuj do schowka
 
 
grzeniosg 
forumowicz


Posty: 15
Wysłany: 19-07-2017, 09:55   

Dzięki wielkie :beer temat do zamknięcia
ID posta: 326407 Skopiuj do schowka
 
 
grzeniosg 
forumowicz


Posty: 15
Wysłany: 24-08-2017, 12:42   

jeszcze w tym temacie mam problemy:

1)w Kolumnie B znajduje się formuła:
Kod:
=SUMA.ILOCZYNÓW((G7:ABV7={1;"UW";"NŻ";"L4";"O";"Z"})*($G$3:$ABV$3<>"TAK"))


tutaj nie wiem jak zrobić aby przy "Z" nie odejmowało godzin jeśli występuje "TAK"w wierszu 3.


2) W kolumnie F chciałbym aby zliczało mi same "Z":
Kod:
=SUMA.ILOCZYNÓW((G7:ABV7="Z"))

w Google Excel zlicza, natomiast w Excelu 2016 już nie.


3) Wiersz 6 oblicza ilość osób na zmianie, mam problem z wyliczeniem tego zwraca mi błąd EQ. W tym wierszu powinno sumować "1" oraz "Z" w danej godzinie.

Edit: Zefirek
Proszę stosować znaczniki [code] do wstawiania kodów makr, kwerend i formuł, Regulamin 3.1


grafik.xlsx
Pobierz Plik ściągnięto 106 raz(y) 42.85 KB

ID posta: 328315 Skopiuj do schowka
 
 
kuma 
Excel Expert


Wersja: Win Office 2010
Pomógł: 1374 razy
Posty: 3957
Wysłany: 24-08-2017, 17:52   

Przetestuj poniższe formuły.
W 'B7' z kopią w dół
Kod:
=SUMA.ILOCZYNÓW((G7:ABV7={1;"UW";"NŻ";"L4";"O";"Z"})*($G$3:$ABV$3<>"TAK"))+SUMA.ILOCZYNÓW((G7:ABV7="Z")*($G$3:$ABV$3="TAK"))
Zliczanie 'Z", w 'F7' i kopia w dół
Kod:
=LICZ.WARUNKI(G7:ABV7;"Z")
Dla zliczania pracowników w 'G6' i kopia w prawo
Kod:
=SUMA.ILOCZYNÓW(--(G7:G11={1\"Z"}))
Pozdrawiam.
ID posta: 328339 Skopiuj do schowka
 
 
grzeniosg 
forumowicz


Posty: 15
Wysłany: 25-08-2017, 09:40   

śmiga :)
ID posta: 328369 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe