Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Przesunięty przez: bodek
30-08-2019, 08:52
funkcja nie działa w ods a działa w google drive excel sheet
Autor Wiadomość
okulistka 
Starszy Forumowicz


Posty: 28
Wysłany: 15-03-2018, 18:52   funkcja nie działa w ods a działa w google drive excel sheet

Dobry wieczór,

chciałabym policzyć ile diagnoz "Albinismus" pojawiło się w zakresie czasowym 1969-1979 (ma wyjść 14). Używam funkcji:

Kod:
=sum(index((len(C3:C1929)-len(substitute(C3:C1929,"Albinismus","")))/len("Albinismus")*(A3:A1929>=date(1969,10,1))*(A3:A1929<=date(1978,12,31))0))

Tak obliczyłam wszystkie diagnozy w google drive excel sheet, ale ta formuła nie działa mi jak otwieram excel ods. Nie rozumiem dlaczego. Czy ktoś mógłby mi pomóc? W załączeniu wersja xlsx bo nie można ods.

Pozdrawiam
KASIA

**********************************************************************************
Edit: Zefirek
Proszę stosować znaczniki [code] przy wstawianiu kodów makr, kwerend i formuł, Regulamin 3.1


Wersja robocza.xlsx
Pobierz Plik ściągnięto 97 raz(y) 56.45 KB

ID posta: 342450 Skopiuj do schowka
 
 
Bill Szysz 
Excel Expert


Wersja: Win Office 365
Pomógł: 887 razy
Posty: 3583
Wysłany: 15-03-2018, 21:07   

Nie znam sie na googlowych czy innych wynalazkach ale możesz sprawdzić te formuły
Kod:
=LICZ.WARUNKI($A$3:$A$1929;">=1969-10-01";$A$3:$A$1929;"<=1978-12-31";$C$3:$C$1929;"*Albinismus*")

Kod:
=SUMA.ILOCZYNÓW(($A$3:$A$1929 >= "1969-10-01"+0)*($A$3:$A$1929<="1978-12-31"+0)*(PODSTAW($C$3:$C$1929;"Albinismus";"")<>$C$3:$C$1929))

Kod:
=SUMA.ILOCZYNÓW(($A$3:$A$1929 >= DATA(1969;10;1))*($A$3:$A$1929<=DATA(1978;12;31))*(PODSTAW($C$3:$C$1929;"Albinismus";"")<>$C$3:$C$1929))

Translator formuł Tutaj
_________________
Zlecenia, konsultacje, doradztwo i szkolenia z Power Query, Power BI i Excela - Raporty, Analizy, Projekty
Pozdrawiam, były szbill62 aktualnie Bill Szysz
ID posta: 342454 Skopiuj do schowka
 
 
okulistka 
Starszy Forumowicz


Posty: 28
Wysłany: 15-03-2018, 21:20   

Pomogło, serdecznie dziękuję!
ID posta: 342455 Skopiuj do schowka
 
 
okulistka 
Starszy Forumowicz


Posty: 28
Wysłany: 16-03-2018, 19:35   w ods nie działa formuła na obliczenie wieku

Drodzy forumowicze,

nie wiem co jest nie tak z formatem ods ale jak kiedyś obliczyłam sobie w tabelce wiek pacjenta, to teraz po aktualizacji programu moje wyniki zamieniły się w płotki. Czy ktoś ma pomysł, dlaczego tak się stało? Może trzeba zmodyfikować formułę?

Pozdrawiam
KASIA

wersja robocza.xlsx
Pobierz Plik ściągnięto 77 raz(y) 53.64 KB

ID posta: 342496 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2661 razy
Posty: 4477
Wysłany: 16-03-2018, 20:11   

spróbuj
Kod:
=DATA.RÓŻNICA(A3;B3;"y")
_________________
Pozdrawiam
Asia
ID posta: 342497 Skopiuj do schowka
 
 
okulistka 
Starszy Forumowicz


Posty: 28
Wysłany: 17-03-2018, 10:48   

Działa w google drive excel sheet, ale niestety nie działa w formacie ods :(
ID posta: 342516 Skopiuj do schowka
 
 
Bill Szysz 
Excel Expert


Wersja: Win Office 365
Pomógł: 887 razy
Posty: 3583
Wysłany: 17-03-2018, 12:20   

okulistka, przejdź na excela bo inne pakiety mają od zawsze (a przynajmniej odkąd pamiętam) kłopoty z kompatybilnością wsteczną.
Możesz spróbować takiej formuły ( ograniczyłem się do podstawowych funkcji które prawdopodobnie występują też w OpenOffice)
Kod:
=ROK(B3)-ROK(A3)-(DATA(1900;MIESIĄC(B3);DZIEŃ(B3))<DATA(1900;MIESIĄC(A3);DZIEŃ(A3)))

Powyższa formuła jest delikatnie niepoprawna ale błąd wystąpi tylko w bardzo szczególnym przypadku (różnica jednego roku w wieku) który z dużą dozą prawdopodobieństwa nie wystąpi u Ciebie.
_________________
Zlecenia, konsultacje, doradztwo i szkolenia z Power Query, Power BI i Excela - Raporty, Analizy, Projekty
Pozdrawiam, były szbill62 aktualnie Bill Szysz
ID posta: 342525 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe