Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Przesunięty przez: bodek
06-07-2014, 20:51
Konkurs No_18
Autor Wiadomość
matdob 
Fan Excela



Pomógł: 8 razy
Posty: 87
Wysłany: 25-10-2012, 14:22   Konkurs No_18

Witam,

Jak zliczyć w zakresie w kolumnie B wszystkie komórki w których tekst zaczyna się od jednego z poniższych łańcuchów:
8-
9-
10-
11-

Naklepałem formułę:
Kod:
=LICZ.JEŻELI(B$2:B$15;"8-*")+LICZ.JEŻELI(B$2:B$15;"9-*")+LICZ.JEŻELI(B$2:B$15;"10-*")+LICZ.JEŻELI(B$2:B$15;"11-*")

...ale mi się nie podoba, brzydka jakaś taka - długa ;)

Chciałbym, to zrobić wyrażeniem regularnym (gwiazdki, pytajniki itp.). Bez VBA.

Może macie jakieś pomysły?

Pozdrawiam,
Mateusz

Dni_pracy.zip
Pobierz Plik ściągnięto 312 raz(y) 6.08 KB

ID posta: 174240 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2768 razy
Posty: 4642
Wysłany: 25-10-2012, 15:52   

tablicowa
Kod:
=SUMA(JEŻELI(CZY.BŁĄD(SZUKAJ.TEKST({"8-*";"9-*";"10-*";"11-*"};C2:C40;1));0;1))
_________________
Pozdrawiam
Asia
ID posta: 174270 Skopiuj do schowka
 
 
matdob 
Fan Excela



Pomógł: 8 razy
Posty: 87
Wysłany: 25-10-2012, 16:10   

Asia_@., chytre. Wygląda zupełnie sensownie, ale nie wiedzieć czemu wyświetla mi 0. Patrz załącznik - komórka C42.

Dni_pracy2.zip
Pobierz Plik ściągnięto 316 raz(y) 8.16 KB

ID posta: 174273 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2768 razy
Posty: 4642
Wysłany: 25-10-2012, 16:25   

jest to formuła tablicowa, zatwierdza się ją Enterem trzymając
wciśnięte CTRL+SHIFT
_________________
Pozdrawiam
Asia
ID posta: 174275 Skopiuj do schowka
 
 
matdob 
Fan Excela



Pomógł: 8 razy
Posty: 87
Wysłany: 25-10-2012, 19:04   

Jasne. Ale nadal nie działa :)

Dni_pracy2.zip
Pobierz Plik ściągnięto 276 raz(y) 8 KB

ID posta: 174294 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2768 razy
Posty: 4642
Wysłany: 25-10-2012, 19:07   

nie mam 2007, więc trudno mi odpowiedzieć
zapisz w 2003
_________________
Pozdrawiam
Asia
ID posta: 174295 Skopiuj do schowka
 
 
SGJ 
Excel Expert



Pomógł: 1006 razy
Posty: 2220
Wysłany: 25-10-2012, 19:45   

matdob formuła w Twoim pliku
Kod:
=SUMA(JEŻELI(CZY.BŁĄD(SZUKAJ.TEKST({"8-*"\"9-*"\"10-*"\"11-*"};C2:C40;1));0;1))

formuła którą podała Asia_@.
Kod:
=SUMA(JEŻELI(CZY.BŁĄD(SZUKAJ.TEKST({"8-*";"9-*";"10-*";"11-*"};C2:C40;1));0;1))

wiesz teraz dlaczego nie działa?
_________________
Sławek
ID posta: 174307 Skopiuj do schowka
 
 
matdob 
Fan Excela



Pomógł: 8 razy
Posty: 87
Wysłany: 25-10-2012, 20:24   

Racja, miałem niepoprawną formułę. Przypuszczam, że coś się przy kopiowaniu z przeglądarki poprzestawiało. Zwracam honor Asiu a wszystkim pięknie dziękuję za pomoc :)
ID posta: 174312 Skopiuj do schowka
 
 
hurgadion 
ExcelSpec



Pomógł: 1080 razy
Posty: 2447
Wysłany: 25-10-2012, 21:29   

Witam,
proponuję formułkę tablicową:
Kod:

=SUMA(JEŻELI(LEWY(B2:B15;ZNAJDŹ("-";B2:B15)-1)*1<12;1;0))

Pozdrawiam.
_________________
miasto nauki
ID posta: 174324 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe