Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 60760 Skopiuj do schowka Jednoformułowy "wisielec" :)
Autor Wiadomość
DwaNiedźwiedzie 
Excel Expert



Pomógł: 213 razy
Posty: 549
Wysłany: 13-03-2018, 01:02   Jednoformułowy "wisielec" :)

1) W menu Plik -> Opcje -> Formuły włączamy obliczenia iteracyjne, a jako maksymalną liczbę iteracji ustawiamy jeden.
2) W komórce B1 wpisujemy poniższą formułę:
Kod:
=JEŻELI(C1="";POWT("*";DŁ(A1))&ZNAK(10)&"prób: "&3;JEŻELI(LUB(B1="wygrałeś!";B1="przegrałeś!");B1;JEŻELI(PODSTAW(LEWY(B1;DŁ(A1));"*";C1;1)=A1;"wygrałeś!";JEŻELI.BŁĄD(LEWY(B1;ZNAJDŹ(C1;A1;JEŻELI.BŁĄD(ZNAJDŹ("|";PODSTAW(B1;C1;"|";DŁ(LEWY(B1;DŁ(A1)))-DŁ(PODSTAW(LEWY(B1;DŁ(A1));C1;""))))+1;1))-1)&C1&PRAWY(LEWY(B1;DŁ(A1)); DŁ(A1)-ZNAJDŹ(C1;A1;JEŻELI.BŁĄD(ZNAJDŹ("|";PODSTAW(B1;C1;"|";DŁ(LEWY(B1;DŁ(A1)))-DŁ(PODSTAW(LEWY(B1;DŁ(A1));C1;""))))+1;1)))&PRAWY(B1;8);JEŻELI(--PRAWY(B1;1)<2;"przegrałeś!";LEWY(B1;DŁ(B1)-1)&PRAWY(B1;1)-1)))))

3) W komórce A1 wpisujemy jakieś hasło (np. "abrakadabra").
4) W C1 podajemy zgadywaną literę :)

Graficznie może trochę ustępuje popularnemu ostatnio formułowemu Doomowi, ale... No dobra, nie ma ale, chciałem sprawdzić, co to są te iteracje :)
ID posta: 342258 Skopiuj do schowka
 
 
Marecki 
Excel Expert



Wersja: Win Office 2019
Pomógł: 2082 razy
Posty: 6876
Wysłany: 14-03-2018, 13:12   

Ciekawy sposób wykorzystania iteracji :cool1
_________________
Hardware - ta część komputera, którą można kopnąć kiedy software przestanie funkcjonować.

Szkolenia z Excela , FB
Office 2019 Professional Plus , Windows 10 x64
Pozdrawiam, były mkkk23 teraz Marecki.
ID posta: 342362 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe