Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70595 Skopiuj do schowka Zwracanie wyniku zgodnie z prawdopodobieństwem
Autor Wiadomość
Roll0 
Świeżak


Wersja: Mac Office 2016
Posty: 2
Wysłany: 08-04-2021, 19:34   Zwracanie wyniku zgodnie z prawdopodobieństwem

Cześć!
Prośba o pomoc w skonstruowaniu formuły dla poniższego zagadnienia:

Dla % prawdopodobieństwa wystąpienia danego wyniku:
Win - 30%
Loss - 60%
BE - 10%

Przyporządkować odpowiednią wartość w tabeli 60 wystąpień:
1 - ...
2 - ...
3 - ...
4 - ...
...
60 - ...

Mam nadzieję, że w miarę jasno opisałem zagadnienie. Z góry dziękuję za wsparcie :)
ID posta: 403311 Skopiuj do schowka
 
 
Kaper 



Zaproszone osoby: 2
Wersja: Win Office 365
Pomógł: 4228 razy
Posty: 7959
Wysłany: 09-04-2021, 14:33   

Jeśli przygotujesz tabelę, w której zestawisz prawdopodobieństwa wystąpienia zdarzeń "mniejszych" (czyli występujących na liście przed bieżącym zdarzeniem) to możesz sprawdzać, jakiemu zdarzeniu odpowiada losowa liczba.

Brzmi skomplikowanie, więc zobacz załącznik.

Główna formuła to:
Kod:
=INDEKS($A$4:$A$6;PODAJ.POZYCJĘ(LOS();$C$4:$C$6;1))


A4:A6 to nazwy Twoich zdarzeń, a w C4:C6 są prawdopodobieństwa, że wystąpiło zdarzenie "mniejsze niż Win" = 0 (nie ma zdarzeń na liście powyżej win
Mniesze niż loss = 0,3 (bo, tylko win jest powyżej)
miejsze niż BE = 0,9 (bo win=0,3 i loss = 0,6) są powyżej BE

Tabelka z boku pozwala obserwować jakość losowania.

i wg mnie wynik np.:
Win 17 28,33%
Loss 40 66,67%
BE 3 5,00%

albo
Win 16 26,67%
Loss 38 63,33%
BE 6 10,00%

jest prawidłowy.
Tak jak wynik obu orłów czy obu reszek jest możliwy, choć każdy z nich o połowę mniej prawdopodobny niż orzeł i reszka przy rzucie dwoma monetami)

Ale oczywiście można się uprzeć i "zmusić excela do osiągnięcia podziału
Win 18 30,00%
Loss 36 60,00%
BE 6 10,00%

To pokazałem w drugim arkuszu, gdzie w kolumnie pomocniczej (możesz ją ukryć) wpisałem liczby pseudolosowe (funkcja LOS) a potem przypisywałem wynikom z pierwszych (najmniejszych) 30% wartości wylosowanych wynik WIN, pierwszym 90%, a nie tym rozpoznanym jako pierwsze 30% wynik LOSS, a całej reszcie BE.

To oczywiście inne pytanie niż "rozumienie wprost" pytania, al;e na wszelki wypadek podaję i takie.
jeśli wartości pomocnicze są w kolumnie E to formuła może wyglądać tak:
Kod:
=JEŻELI(D2<=MIN.K(D:D;$B$4*ILE.LICZB(D:D));$A$4;JEŻELI(D2<=MIN.K(D:D;SUMA($B$4:$B$5*ILE.LICZB(D:D)));$A$5;$A$6))
zamiast ILE.LICZB można oczywiście wstawić 60 podobnie jak w pierwszej formule - też można było wpisać 60 zamiast ile.niepustych

losowanie z prawdopodobieństwem.xlsx
Pobierz Plik ściągnięto 7 raz(y) 15.29 KB

_________________
Kaper Jej Królewskiej Mości :boss

Jeśli dane będą torturowane dość długo, przyznają się do wszystkiego
ID posta: 403337 Skopiuj do schowka
 
 
Roll0 
Świeżak


Wersja: Mac Office 2016
Posty: 2
Wysłany: 09-04-2021, 16:05   

Dziękuję :)
ID posta: 403344 Skopiuj do schowka
 
 
Kaper 



Zaproszone osoby: 2
Wersja: Win Office 365
Pomógł: 4228 razy
Posty: 7959
Wysłany: 12-04-2021, 12:43   

Jak rozumiem - zadziałało.
Super.
A która wersja była tą właściwą? Ta z prawdopodobieństwem pojedynczego zdarzenia, czy ta z zadanym podziałem wyników na podgrupy?
_________________
Kaper Jej Królewskiej Mości :boss

Jeśli dane będą torturowane dość długo, przyznają się do wszystkiego
ID posta: 403444 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe