Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 55470 Skopiuj do schowka Zmiana układu danych z poziomego na pionowy
Autor Wiadomość
winer at least
Exceloholic


Pomógł: 2 razy
Posty: 199
Wysłany: 04-01-2017, 15:47   Zmiana układu danych z poziomego na pionowy

Mam tabelę za pomocą której wpisując nazwę firmy [ABC] poniżej z automatu wpisuje się nazwa ulicy i miasto.
Stan obecny /zakładka TERAZ/ mam dane nazw firm z adresami w układzie poziomym.
Sprawia to trudność,gdyż muszę przewijać w prawo ,aby zobaczyć dane firmy do kliknięcia.
Zakładka ZAMIAR ,to jest układ ,który pragnę osiągnąć,czyli nazwy firm w układzie pionowym,widoczne wszystkie firmy jednocześnie.
Proszę o pomoc z napisaniu formuły ,która by "czytała" dane w układzie pionowym.
Dziękuję bardzo

dane..xls
Pobierz Plik ściągnięto 13 raz(y) 14 KB

ID posta: 312050 Skopiuj do schowka
 
 
rubex 
świeżak


Pomógł: 2 razy
Posty: 2
Wysłany: 04-01-2017, 21:09   

Hej

Jeśli ma office 2013 to nie potrzebujesz żadnej formuły aby to osiągnąć, wystarczy zaznaczyć obszar który Cię interesuje PKM wklej specjalnie Transpozycja.

Jeśli ma starszą wersje Office to użyj funkcji tablicowej transponuj
Kod:
{=TRANSPONUJ(Teraz!A2:AV4)}


W załączniku przesyłam Ci w arkuszu

dane..xls
Pobierz Plik ściągnięto 15 raz(y) 36.5 KB

ID posta: 312097 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 767 razy
Posty: 2447
Wysłany: 04-01-2017, 22:52   

Jeśli chcesz taką formę jak w arkuszu 'Zamiar' to w 'G2' formuła z kopią w prawo i w dół
Kod:
=JEŻELI.BŁĄD(INDEKS(Teraz!$G$2:$AV$4;JEŻELI(MOD(WIERSZ($A1);4)=0;"";MOD(WIERSZ($A1);4));JEŻELI(LICZBA.KOLUMN($G$2:G2)<=10;10*ZAOKR.DÓŁ(WIERSZ(A1)/4;0)+LICZBA.KOLUMN($G$2:G2);""));"")
Pozdrawiam.
ID posta: 312102 Skopiuj do schowka
 
 
winer at least
Exceloholic


Pomógł: 2 razy
Posty: 199
Wysłany: 05-01-2017, 09:43   

Dziękuję Kolegom za pomoc.
Jednak nie jest to to,czego bym pragnął.
Zapytam tak:
jaka formułę należy wpisać do A3,aby niezależnie od tego ,którą miejscowość wybierzemy
wpisywane zostały/w A3,A4 / ulice i miejscowości odpowiednie do danej firmy?
ID posta: 312146 Skopiuj do schowka
 
 
winer at least
Exceloholic


Pomógł: 2 razy
Posty: 199
Wysłany: 06-01-2017, 12:47   

Proszę spojrzeć teraz na załącznik.
Może ktoś znajdzie sposób?
Dziękuję
Pozdrawiam serdecznie

dane.nowe.6.1.xls
Pobierz Plik ściągnięto 7 raz(y) 11 KB

ID posta: 312306 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 1829 razy
Posty: 3073
Wysłany: 06-01-2017, 13:10   

w A3 formuła tablicowa
Kod:
=INDEKS($G$2:$P$12;MIN.K(JEŻELI(NIE(CZY.BŁĄD(ZNAJDŹ($A$2;$G$2:$P$12)));WIERSZ($G$2:$P$12)-1;"");1)+WIERSZ(1:1);MIN.K(JEŻELI(NIE(CZY.BŁĄD(ZNAJDŹ($A$2;$G$2:$P$12)));NR.KOLUMNY($G$2:$P$12)-6;"");1))

i kopia w dół
_________________
Pozdrawiam
Asia
ID posta: 312309 Skopiuj do schowka
 
 
Tadek
Excel Expert


Pomógł: 762 razy
Posty: 3318
Wysłany: 06-01-2017, 13:24   

Można również za pomocą makra.
Zobacz w załączniku.

dane.nowe.6.1 - Kopia.xls
Pobierz Plik ściągnięto 7 raz(y) 36 KB

ID posta: 312311 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum


Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.