Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 3125 Skopiuj do schowka Zliczanie wartości gdy występują komórki scalone
Autor Wiadomość
zachu
[Usunięty]

Wysłany: 27-09-2007, 19:34   Zliczanie wartości gdy występują komórki scalone

Kłopot mój polega na zliczaniu danych w zależności od kolumny w której istnieją scalone komórki.
Czytając inne posty nie natrafiłem na podobny temat.
Wyjaśnienie problemu:
Zakładając, że w kolumnie "A" poszczególne komórki opisuję tekstowo np: DOSTAWA, USŁUGA itp., i niektóre z nich scalam.
W kolumnie B podaję wartości poszczególnych transakcji, jednak komórki nie zawsze są scalone i wartości mogą występować w kilku wierszach.
Przykładowo A1 do A3 scalone jako DOSTAWA. Lecz w B1 występuje wartość, w B2 również i to samo w B3.
Jak zliczyć sumę wartości transakcji z kolumny "B" jeżeli w kolumnie "A" występuje np. DOSTAWA? Oczywiście przykład mocno uprościłem, chodzi o ideę.
Proszę o pomoc i dziękuję wszystkim za czas poświęcony choćby na czytanie cudzych problemów:)
ID posta: 16295 Skopiuj do schowka
 
 
zubel 
ExcelSpec



Pomógł: 333 razy
Posty: 566
Wysłany: 27-09-2007, 19:59   

jeżeli możesz mieć dodatkową kolumnę np C
wtedy w C1
Kod:

=JEŻELI(A1=0;0;A1)

a w C2
Kod:

=JEŻELI(A2=0;C1;A2)

i dalej jak w C2 (skopiuj)

i teraz dla wyniku np
Kod:

=SUMA.JEŻELI($C$1:$C$11;E1;$B$1:$B$11)
_________________
zubel
ID posta: 16296 Skopiuj do schowka
 
 
Waldek 
ExcelSpec


Wersja: Win Office 2019
Pomógł: 156 razy
Posty: 766
Wysłany: 27-09-2007, 20:25   

Ja osobiście unikam scalania komórek i innym radzę też tak robić. Scalone komórki mogą powodować różne utrudnienia, nawet problemy z przewijaniem ekranu. Jeżeli tylko potrzeba wyśrodkować napis to radzę zastosować "Formatuj komórki, Wyrównanie, Wyrównaj zaznaczenie do środka".
ID posta: 16299 Skopiuj do schowka
 
 
bodek 


Wersja: Win Office 2019
Pomógł: 954 razy
Posty: 2739
Wysłany: 27-09-2007, 20:26   

Waldek napisał/a:
Ja osobiście unikam scalania komórek i innym radzę też tak robić. Scalone komórki mogą powodować różne utrudnienia, nawet problemy z przewijaniem ekranu. Jeżeli tylko potrzeba wyśrodkować napis to radzę zastosować "Formatuj komórki, Wyrównanie, Wyrównaj zaznaczenie do środka".

Podpisuję się pod powyższym rękami i nogami. :mrgreen:
_________________
Szkolenia z Excela, Power Query, Power Pivot, wizualizacje danych w Excelu
ID posta: 16300 Skopiuj do schowka
 
 
Andrzejz
[Usunięty]

Wysłany: 27-09-2007, 21:21   

Ja osobiście nie mam nic przeciwko scalaniu komórek. Ma to sens jeżeli obliczenia odbywają się też w obrębie scalanych komórek. Jest to oczywiście kwestia potrzeby a nie reguła.
Z poważaniem.
Andrzej Z.
ID posta: 16305 Skopiuj do schowka
 
 
zachu
[Usunięty]

Wysłany: 27-09-2007, 21:30   

zubel - WIELKIE dzięki. Fajnie wykombinowane.
Problem rozwiązany i temat można zamknąć.
Pozdrawiam.
ID posta: 16308 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe