Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64432 Skopiuj do schowka Zliczanie dni w zależności od warunku
Autor Wiadomość
dominikfil 
Starszy Forumowicz


Wersja: Win Office 2007
Posty: 42
Wysłany: 14-03-2019, 15:27   Zliczanie dni w zależności od warunku

Mam pytanie,
czy da się w miarę prosto przy pomocy formuły zrobić coś takiego.

Pracownik w styczniu był na chorobowym przed dwa tyg. ciągiem wraz z sobotami i niedzielami czyli 14 dni
w lutym był od pon. do pt. - czyli 10 dni

Chciałbym na koniec roku oprócz zwykłego zesumowania tych dnia z każdego miesąca czyli 14+10=24 dni również aby mi policzyło te dane z pominięciem sobów i niedziel w które było też zwolnienie. Czyli wynik 12+10=22 dni.

W arkuszu ewidencja roczna przy poz. Choroba chciałbym liczyć te dnia bez sobót i niedziel.

Mam jak widać w pliku sobotę i niedzielę oznaczoną kolorem szarym i czerwonym. Te dni się zmieniają w zależności od miesiąca i roku.
Czy można to jakość zrobić, aby w każdym roku było liczone poprawnie?

Ewid roczna.xlsx
Pobierz Plik ściągnięto 21 raz(y) 186.82 KB

ID posta: 364228 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2391 razy
Posty: 4064
Wysłany: 14-03-2019, 16:10   

w arkuszu Styczeń, w AI24
Kod:
=JEŻELI(AH24=1;SUMA.ILOCZYNÓW((DZIEŃ.TYG(C12:AG12;2)<6)*(C24:AG24="*"));"")

i analogicznie dla pozostałych arkuszy
_________________
Pozdrawiam
Asia
ID posta: 364235 Skopiuj do schowka
 
 
dominikfil 
Starszy Forumowicz


Wersja: Win Office 2007
Posty: 42
Wysłany: 14-03-2019, 23:39   

Zrobiłem to w arkuszu ewidencja roczna:
Cytat:
JEŻELI(Luty!$AH$23=1;SUMA.ILOCZYNÓW((DZIEŃ.TYG(Luty!$C$12:$AE$12;2)<6)*(Luty!$C$23:$AE$23="*"));"")

i działa z jednym wyjątkiem jak w lutym np. w 2020 r. będzie 29 dni to już nie działa, albo jak ustawie dla Lutego 2020 i działa to po zmianie na luty z 28 dniami też nie działa.
Można to jakość obejść?

Chodzi o tą końcówkę AE dla 28 dni lub AD dla 29 dni.
ID posta: 364261 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2391 razy
Posty: 4064
Wysłany: 15-03-2019, 08:00   

Kod:
=JEŻELI(AH23=1;SUMA.ILOCZYNÓW((DZIEŃ.TYG(PRZESUNIĘCIE(C12;;;;ILE.LICZB(C12:AG12));2)<6)*(PRZESUNIĘCIE(C23;;;;ILE.LICZB(C12:AG12))="*"));"")

albo
Kod:
=JEŻELI(AH23=1;SUMA.ILOCZYNÓW((DZIEŃ.TYG(C12:INDEKS(C12:AG12;;ILE.LICZB(C12:AG12));2)<6)*(C23:INDEKS(C23:AG23;;ILE.LICZB(C12:AG12))="*"));"")
_________________
Pozdrawiam
Asia
ID posta: 364266 Skopiuj do schowka
 
 
dominikfil 
Starszy Forumowicz


Wersja: Win Office 2007
Posty: 42
Wysłany: 15-03-2019, 10:29   

Asia_@. dziękuję bardzo za pomoc.
Te dwie formuły to można zastosować do wszystkich miesięcy, aby nie bawić się już tylko z Lutym w inną. :) :-)
ID posta: 364285 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe