Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63785 Skopiuj do schowka Zamiana godziny na liczbę całkowitą
Autor Wiadomość
aloyzz
forumowicz


Posty: 14
Wysłany: 12-01-2019, 21:45   Zamiana godziny na liczbę całkowitą

Witam.
Po ustaleniu różnicy godzin między dwoma datami chciałbym wynik (zaokrąglony do pełnej godziny) przemnożyć przez pewną wartość. Niestety excel nie traktuje godzin jak liczbę całkowitą.
W przypadku krótkiej różnicy między datami nie ma problemu, ale większa liczba godzin powoduje błędne liczenie. Próbowałem użyć funkcji ZAOKR ale jak widać w załączonym pliku nie w każdym przypadku to pomaga. Podobnie jest z funkcją LICZ.CAŁK. Da się jakoś zamienić te godziny na liczby całkowite?

Pozdrawiam.

godziny.xlsx
Pobierz Plik ściągnięto 17 raz(y) 9.88 KB

ID posta: 360324 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 1214 razy
Posty: 3602
Wysłany: 12-01-2019, 23:12   

Jeśli Cię dobrze zrozumiałem to w I3
Kod:
=(DATA(E3;F3;G3)+H3)-(DATA(A3;B3;C3)+D3)
Komórki w kol. I sformatuj niestandardowo [gg] jeśli mają być wyświetlane tylko godziny.
Pozdrawiam.
ID posta: 360325 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 339 razy
Posty: 1805
Wysłany: 12-01-2019, 23:32   

Kod:
=ZAOKR.GÓRA((DATA(E3;F3;G3)+H3)-(DATA(A3;B3;C3)+D3);2)
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
I dbajmy - proszę - o poprawną polszczyznę.
ID posta: 360326 Skopiuj do schowka
 
 
Waldek 
ExcelSpec


Wersja: Win Office 2019
Pomógł: 127 razy
Posty: 649
Wysłany: 13-01-2019, 02:36   

Formuła w I3:
Kod:
=JEŻELI.BŁĄD(24*ZAOKR.W.GÓRĘ((DATA(E3;F3;G3)+H3)-(DATA(A3;B3;C3)+D3);CZAS(1;0;0));"")

Jest to już liczba całkowita ilości godzin, więc sformatowana ma być jako liczba. Dlatego w K3 formuła:
Kod:
=I3*J3

Dodaję załącznik:

godziny (3).xlsx
Pobierz Plik ściągnięto 10 raz(y) 9.6 KB

ID posta: 360332 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe