Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64024 Skopiuj do schowka Wyszukiwanie w tabeli
Autor Wiadomość
crrs11 
świeżak


Posty: 2
Wysłany: 03-02-2019, 21:02   Wyszukiwanie w tabeli

Witam,
chodzi mi o to żeby dopisać 1 do lat 2019 i 2017 a zera do lat 2018 i 2016.
Funkcja
Kod:
=JEŻELI($C$2:$C$3=A2;1;0)
nie działa, co zrobiłem złe?
chce zeby to tak wyglądało.


Z góry dziękuje za pomoc.
ID posta: 361886 Skopiuj do schowka
 
 
maxaa 
ExcelSpec



Pomógł: 192 razy
Posty: 918
Wysłany: 03-02-2019, 21:57   

Wstaw w komórce B2 poniższą formułę i przeciągnij w dół.
Kod:
=JEŻELI(LUB(A3:A8=2019;A3:A8=2017);1;0)
ID posta: 361887 Skopiuj do schowka
 
 
Tadek
Excel Expert


Pomógł: 1507 razy
Posty: 4815
Wysłany: 04-02-2019, 09:17   

Witaj na forum.
W B2 wstaw:
Kod:
=JEŻELI(MOD(A2;2)=0;0;1)
i przeciągnij w dół.

W C2 wstaw:
Kod:
=JEŻELI(B2=1;A2;"")
i przeciągnij w dół.

Pozdrawiam Tadek
ID posta: 361898 Skopiuj do schowka
 
 
crrs11 
świeżak


Posty: 2
Wysłany: 04-02-2019, 20:46   

Dzięki za zainteresowanie, ale nie dok końca mi o to chodziło. To był tylko mały przykład. W rzeczywistości chodzi mi o to ze muszę z kolumny pierwszej wyszukać około 300 numerów seryjnych urządzeń które w ostatnim czasie były używane. Czyli mam listę ponad 400 N/S (kolumna A) urządzeń dostaje listę około 300 N/S (kolumna C) które były używane i muszę dopisać w kolumnie B "był używany" lub "nie był używany". Więc musi to być zakres (około 300 wpisów z kolumny C) a nie na sztywno wpisane dwa warunki. Da się tak ??
ID posta: 361950 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1230 razy
Posty: 4264
Wysłany: 04-02-2019, 21:53   

Kod:

=JEŻELI(LICZ.JEŻELI(C$2:C$300;A2);"używane";"nieużywane")
ID posta: 361958 Skopiuj do schowka
 
 
Tadek
Excel Expert


Pomógł: 1507 razy
Posty: 4815
Wysłany: 05-02-2019, 07:22   

Cytat:
Dzięki za zainteresowanie, ale nie dok końca mi o to chodziło. To był tylko mały przykład
W przyszłości pisz dokładniej o co chodzi (teraz całkowicie chcesz coś innego), a najlepiej to podłączaj przykładowy plik (a nie obrazek) i w nim dokładnie pokaż co masz i co chcesz mieć.
ID posta: 361969 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe