Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 55480 Skopiuj do schowka Wyszukiwanie
Autor Wiadomość
drak_2
świeżak


Posty: 2
Wysłany: 04-01-2017, 23:02   Wyszukiwanie

Witam,
Mama pewien problem z wyszukiwaniem tekstu. Mając listę nazwisk
1. Nowak Jan
2. Adamek Piotr
3. Nowak Tomasz
4. Kwiatkowski Artur

chcę znaleźć wszystkich o nazwisku Nowak. Próbowałem już z funkcją wyszukaj pionowo i wyszukiwanie po fragmencie tekstu, lecz ten zabieg powoduje pokazanie tylko pierwszego nazwiska które pojawia się na liście. Czy istnieje jakiś niezbyt skomplikowany sposób aby to osiągnąć?

Z góry dziękuję za pomoc.
ID posta: 312103 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 785 razy
Posty: 2758
Wysłany: 05-01-2017, 00:05   

Proponuję nagłówki w wierszu 1 np. A1 = Nazwisko i Imię, B1 = Szukane nazwisko:, C1 = Nowak. W ten sposób zmieniąc C1 mamy od razu nowe wyniki dla nowego nazwiska.
dane od wiersza 2
formuła dla C2
Kod:

=JEŻELI.BŁĄD(INDEKS($A$2:$A$100;PODAJ.POZYCJĘ(1;INDEKS(LICZ.JEŻELI($C$1:$C1;$A$2:$A$100)+CZY.LICZBA(SZUKAJ.TEKST(" " & $C$1 & " ";" " & $A$2:$A$100));0);0));"")

Ale przecież nazwisko to nie tylko Nowak, w Polsce są jeszcze Nowak-Ptak lub Ptak-Nowak. Dla tych 3 przypadków proponuję
Kod:

=JEŻELI.BŁĄD(INDEKS($A$2:$A$100;PODAJ.POZYCJĘ(1;INDEKS(LICZ.JEŻELI($C$1:$C1;$A$2:$A$100)+CZY.LICZBA(SZUKAJ.TEKST(" " & $C$1 & " ";" " & PODSTAW($A$2:$A$100;"-";" ")));0);0));"")
ID posta: 312105 Skopiuj do schowka
 
 
drak_2
świeżak


Posty: 2
Wysłany: 05-01-2017, 00:12   

Bardzo dziękuję :)
ID posta: 312107 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum


Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.