Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Zamknięty przez: Marecki
22-01-2017, 21:03
Wyszukiwanie
Autor Wiadomość
drak_2
świeżak


Posty: 2
Wysłany: 04-01-2017, 23:02   Wyszukiwanie

Witam,
Mama pewien problem z wyszukiwaniem tekstu. Mając listę nazwisk
1. Nowak Jan
2. Adamek Piotr
3. Nowak Tomasz
4. Kwiatkowski Artur

chcę znaleźć wszystkich o nazwisku Nowak. Próbowałem już z funkcją wyszukaj pionowo i wyszukiwanie po fragmencie tekstu, lecz ten zabieg powoduje pokazanie tylko pierwszego nazwiska które pojawia się na liście. Czy istnieje jakiś niezbyt skomplikowany sposób aby to osiągnąć?

Z góry dziękuję za pomoc.
ID posta: 312103 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1085 razy
Posty: 3717
Wysłany: 05-01-2017, 00:05   

Proponuję nagłówki w wierszu 1 np. A1 = Nazwisko i Imię, B1 = Szukane nazwisko:, C1 = Nowak. W ten sposób zmieniąc C1 mamy od razu nowe wyniki dla nowego nazwiska.
dane od wiersza 2
formuła dla C2
Kod:

=JEŻELI.BŁĄD(INDEKS($A$2:$A$100;PODAJ.POZYCJĘ(1;INDEKS(LICZ.JEŻELI($C$1:$C1;$A$2:$A$100)+CZY.LICZBA(SZUKAJ.TEKST(" " & $C$1 & " ";" " & $A$2:$A$100));0);0));"")

Ale przecież nazwisko to nie tylko Nowak, w Polsce są jeszcze Nowak-Ptak lub Ptak-Nowak. Dla tych 3 przypadków proponuję
Kod:

=JEŻELI.BŁĄD(INDEKS($A$2:$A$100;PODAJ.POZYCJĘ(1;INDEKS(LICZ.JEŻELI($C$1:$C1;$A$2:$A$100)+CZY.LICZBA(SZUKAJ.TEKST(" " & $C$1 & " ";" " & PODSTAW($A$2:$A$100;"-";" ")));0);0));"")
ID posta: 312105 Skopiuj do schowka
 
 
drak_2
świeżak


Posty: 2
Wysłany: 05-01-2017, 00:12   

Bardzo dziękuję :)
ID posta: 312107 Skopiuj do schowka
 
 
jaber
forumowicz


Posty: 12
Wysłany: 22-01-2017, 17:42   

Witam, jak prosto i szybko rozdzielić w osobnych kolumnach imię od nazwiska, mając podane w komórce pełne dane np. Jan Kowalski, Adam Nowak?
ID posta: 313669 Skopiuj do schowka
 
 
Marecki 
Excel Expert



Pomógł: 1815 razy
Posty: 6014
Wysłany: 22-01-2017, 21:03   

jaber, post nie w temacie.
Proszę umieszczać wątki w odpowiednich działach, nadając im odpowiedni tytuł.
Ten wątek zamykam.
_________________
Hardware - ta część komputera, którą można kopnąć kiedy software przestanie funkcjonować.

Szkolenia z Excela , FB
Excel 2010 , Windows 7 x86
Pozdrawiam, były mkkk23 teraz Marecki.
ID posta: 313678 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Ten temat jest zablokowany bez możliwości zmiany postów lub pisania odpowiedzi
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum


Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.