Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 68522 Skopiuj do schowka Wyszukiwanie i porównywanie tych samych wartości
Autor Wiadomość
grzeniosg 
forumowicz


Posty: 15
Wysłany: 15-07-2020, 15:04   Wyszukiwanie i porównywanie tych samych wartości

Witam,

Mam problem w Excelu z formułą, próbowałem wyszukaj pionowo ale chyba to zły trop, mój problem polega na tym, że mam dwa zakresy tabeli, chciałbym porównać dane z kolumny z tabeli E i F z tabelą z kolumny A i B jeśli wartości się zgadzają to wtedy zwrócić w kolumnie H wartość 1

Problem jaki napotkałem to data nie wiem jak mogę go przekonwertować w kolumnie A na format 2020-07-02 11(rrrr-mm-dd gg)

produkty.xls
Pobierz Plik ściągnięto 14 raz(y) 27.5 KB

ID posta: 389696 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2656 razy
Posty: 4476
Wysłany: 15-07-2020, 15:54   

w H2
Kod:
=SUMA.ILOCZYNÓW(--(FRAGMENT.TEKSTU(A$2:A$6;7;4)&"-"&FRAGMENT.TEKSTU(A$2:A$6;4;2)&"-"&LEWY(A$2:A$6;2)&PRAWY(A$2:A$6;DŁ(A$2:A$6)-ZNAJDŹ(" ";A$2:A$6))&B$2:B$6=E2&F2))

i kopia w dół
_________________
Pozdrawiam
Asia
ID posta: 389697 Skopiuj do schowka
 
 
grzeniosg 
forumowicz


Posty: 15
Wysłany: 15-07-2020, 18:15   

Super dziękuje, działa - to jeszcze jedno mam pytanie jakbym chciał to zrobić w drugą stronę?

próbuję kombinować i stworzyłem coś takiego:
Kod:
=SUMA.ILOCZYNÓW(--(FRAGMENT.TEKSTU(E$2:E$24000;9;2)&"."&FRAGMENT.TEKSTU(E$2:E$24000;6;2)&"."&FRAGMENT.TEKSTU(E$2:E$24000;1;4)&PRAWY(E$2:E$24000;DŁ(E$2:E$24000)-ZNAJDŹ(" ";E$2:E$24000))&F$2:F$24000=A2&B2))
i zwraca mi błąd można prosić o informację gdzie leży błąd?
ID posta: 389702 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2656 razy
Posty: 4476
Wysłany: 15-07-2020, 18:56   

Kod:
=SUMA.ILOCZYNÓW(--(E$2:E$24000&F$2:F$24000=FRAGMENT.TEKSTU(A2;7;4)&"-"&FRAGMENT.TEKSTU(A2;4;2)&"-"&LEWY(A2;2)&PRAWY(A2;DŁ(A2)-ZNAJDŹ(" ";A2))&B2))
_________________
Pozdrawiam
Asia
ID posta: 389704 Skopiuj do schowka
 
 
grzeniosg 
forumowicz


Posty: 15
Wysłany: 16-07-2020, 16:12   

Dziękuje, a jak do kolumny C mogę zaciągnąć kwotę z kolumny G aby również wyszukało i porównało po dacie i kodzie produktu?
ID posta: 389754 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 658 razy
Posty: 3465
Wysłany: 16-07-2020, 17:03   

Kod:
=SUMA.ILOCZYNÓW(--(FRAGMENT.TEKSTU(A$2:A$6;7;4)&"-"&FRAGMENT.TEKSTU(A$2:A$6;4;2)&"-"&LEWY(A$2:A$6;2)&PRAWY(A$2:A$6;DŁ(A$2:A$6)-ZNAJDŹ(" ";A$2:A$6))&B$2:B$6=E2&F2))*$G2
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
Chcesz precyzyjną odpowiedź - zadaj precyzyjne pytanie.
ID posta: 389755 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2656 razy
Posty: 4476
Wysłany: 16-07-2020, 18:37   

Kod:
=SUMA.ILOCZYNÓW((E$2:E$24000&F$2:F$24000=FRAGMENT.TEKSTU(A2;7;4)&"-"&FRAGMENT.TEKSTU(A2;4;2)&"-"&LEWY(A2;2)&" "&PRAWY(A2;2)&B2)*G$2:G$24000)
_________________
Pozdrawiam
Asia
ID posta: 389765 Skopiuj do schowka
 
 
grzeniosg 
forumowicz


Posty: 15
Wysłany: 16-07-2020, 20:17   

umiejead, jest przesunięcie o Ciebie o jeden wiersz w dół i nie dopasowuje.

Asia_@., a jak mogę otrzymać tylko jedną kwotę?a dokładnie w przypadku dwóch takich samych wystąpień sumuje mi dwie te kwoty.
ID posta: 389770 Skopiuj do schowka
 
 
grzeniosg 
forumowicz


Posty: 15
Wysłany: 16-07-2020, 22:38   

edit Asia_@., chyba się naprawiło samo bo zlicza pojedyncze
ID posta: 389774 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe