Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 68598 Skopiuj do schowka Wyszukiwanie i oznaczanie duplikatów z warunkiem
Autor Wiadomość
lukmaster80 
Fan Excela


Posty: 64
Wysłany: 27-07-2020, 07:34   Wyszukiwanie i oznaczanie duplikatów z warunkiem

Witam. potrzebowałbym formułę, która wyszukiwałaby zduplikowane dane z kolumny "Dane2" ale tylko dla tego samego numeru z kolumny "Dane1" i zwracała wartość 1 jeśli dane się powtarzają i 0 jeśli się nie powtarzają.
Dziękuję za pomoc


Tytułuj poprawnie wątki.
Wyjątkowo poprawiłem.
umiejead

.

Zeszyt3.xlsx
Pobierz Plik ściągnięto 7 raz(y) 8.94 KB

_________________
Pozdrawiam
  
ID posta: 390183 Skopiuj do schowka
 
 
lukmaster80 
Fan Excela


Posty: 64
Wysłany: 27-07-2020, 08:04   

.... a czy można jeszcze dodać kolejną formułę z tymi samymy warunkami (wyszukiwanie zduplikowanych danych z kolumny "Dane2" ale tylko dla tego samego numeru z kolumny "Dane1") dodatkowa zwracając wartość NIE jeśli ten duplikat występuje pierwszy raz od początku i TAK jeśli jest to już kolejny duplikat...
_________________
Pozdrawiam
ID posta: 390185 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 658 razy
Posty: 3465
Wysłany: 27-07-2020, 08:33   

W C:
Kod:
=JEŻELI(ORAZ(LICZ.JEŻELI($B3:$B$100;$B2)>1;JEŻELI(CZY.BŁĄD(WYSZUKAJ.PIONOWO($A2;$A3:$A$100;1;0));0;1)=1);1;0)
i kopia w dół.

Info: formuła przeszukuje do wiersza 100.
.
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
Chcesz precyzyjną odpowiedź - zadaj precyzyjne pytanie.
  
ID posta: 390187 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 1663 razy
Posty: 5432
Wysłany: 27-07-2020, 08:42   

Zobacz załącznik.

Zeszyt3_duplikaty.xlsx
Pobierz Plik ściągnięto 4 raz(y) 9.12 KB

ID posta: 390188 Skopiuj do schowka
 
 
lukmaster80 
Fan Excela


Posty: 64
Wysłany: 27-07-2020, 08:57   

Dzięki za pomoc, jesteście wielcy :)
_________________
Pozdrawiam
ID posta: 390189 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe