Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 68612 Skopiuj do schowka wyszukaj różne wyrazy na rożnych pozycjach i skopiuj
Autor Wiadomość
MC16R
świeżak


Wersja: Win Office 2016
Posty: 2
Wysłany: 28-07-2020, 15:00   wyszukaj różne wyrazy na rożnych pozycjach i skopiuj

Kopiuję ze słownika takie dane
https://www.ldoceonline.com/dictionary/become
Cytat:
be‧come /bɪˈkʌm/ ●●● S1 W1 verb (past tense became /-ˈkeɪm/, past participle become)
se‧cond‧ment /sɪˈkɒndmənt $ -ˈkɑːnd-/ noun [singular, uncountable] British English


Załóżmy, że są w kolumnie A. Znalazłem taką formułę, która mi pokazuje, czy noun jest w kolumnie A.

Kod:
=CZY.LICZBA(ZNAJDŹ("noun";A1;1))


Dzięki temu mogę wyszukać wszystkie noun i w kolumnie obok mieć wartość noun, po użyciu znajdź i zamień prawda na naun. To samo mogę zrobić z verb, itd. A potem połączyć to wszystko w jedną kolumnę gdzie będę miał te wszystkie części mowy.

Ale chodzi o to, żeby to uprościć.

Czy da się zrobić tak, żeby funkcja znajdowała mi różne części mowy w kolumnie A, czyli wielokrotny warunek, i w kolumnie B mi je pokazywała. Wyrazy noun, verb, adjective, itd. są na różnych pozycjach.

Czyli kolumna B powinna wyglądać na przykład tak:
noun
noun
verb
noun
adjective
ID posta: 390267 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 1663 razy
Posty: 5432
Wysłany: 28-07-2020, 15:43   

Można, ale mógłbyś się postarać o jakiś załącznik. Musisz mieć listę tych słów, których szukasz (nazw części mowy). Możesz ją zrobić w arkuszu, jak w moim przykładzie, możesz też zamienić to na stałą tablicową, możesz nadać nazwę - zarówno zakresowi, jak i stałej tablicowej, co tam Ci odpowiada. Potem np. taka formuła:
Kod:
=INDEKS($J$1:$J$3;PODAJ.POZYCJĘ(PRAWDA;INDEKS(CZY.LICZBA(ZNAJDŹ($J$1:$J$3;A1)););0))
J1:J3 to jest nasza lista, możesz ją rozbudować wg potrzeby, modyfikując odpowiednio adresy.
To będzie działać pod warunkiem, że jedna z szukanych fraz będzie w każdej komórce kol. A i że nie będzie tam kilku różnych fraz w jednej komórce. W tej chwili wyszukiwanie jest wrażliwe na wielkość liter, gdybyś chciał niewrażliwe, to zmień funkcję ZNAJDŹ na SZUKAJ.TEKST.

Znajdź_słowo.xlsx
Pobierz Plik ściągnięto 4 raz(y) 9.06 KB

ID posta: 390272 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe