Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 55473 Skopiuj do schowka Wyszukaj pionowo ze zmiennym zakresem i nr indeksu kolumny
Autor Wiadomość
Miodzi0
forumowicz


Posty: 12
Wysłany: 04-01-2017, 17:00   Wyszukaj pionowo ze zmiennym zakresem i nr indeksu kolumny

Witam,

Mam 3 tabele zawierające
Tabela1
index 1 / cena T1
index 2 / cena T1

Tabela2
Index 1 / cena T2
Index 2 / cena T2

Tabela3
Index 1 / cena T3 ale w kolumnie 4
Index 2 / cena T3 ale w kolumnie 4


następnie w 4 tabeli chciałbym wyszukać cenę w zależności od 2 parametrów indeks oraz nr tabeli

Tabela 4
1 / indeks 1 / funckja która zwróci cene z pierwszej tabeli dla indeksu 1
2 / indeks 1 / -//-
2 / indeks 2 / -//-
3 / indeks 1 / -//-


Ja to zrobic?
ID posta: 312065 Skopiuj do schowka
 
 
Maciej Gonet
Excel Expert


Pomógł: 727 razy
Posty: 2469
Wysłany: 04-01-2017, 17:30   

Przede wszystkim załącz plik Excela z przykładowymi danymi i spodziewanymi wynikami. Opis jest mało precyzyjny, na przykład nie wiadomo, co to dokładnie są tabele (w Excelu to słowo jest używane w kilku znaczeniach), a poza tym raczej nikomu się nie chce tworzyć arkusza przykładowego, bo szansa na dopasowanie układu danych jest niewielka.
ID posta: 312070 Skopiuj do schowka
 
 
Miodzi0
forumowicz


Posty: 12
Wysłany: 04-01-2017, 17:46   

Podpinam plik, gdzie precyzuje o co dokładnie mi chodzi

Wyszukaj pionowa ze zmiennym zakresem.xlsx
Pobierz Plik ściągnięto 12 raz(y) 8.71 KB

ID posta: 312075 Skopiuj do schowka
 
 
Maciej Gonet
Excel Expert


Pomógł: 727 razy
Posty: 2469
Wysłany: 04-01-2017, 18:30   

Na razie coś takiego, o ile dobrze zrozumiałem.
Zakresy tablic poprawiłem. Czy listy indeksów we wszystkich tabelach są jednakowe jak w przykładzie?
Kod:
=WYSZUKAJ.PIONOWO(C22;ADR.POŚR(WYSZUKAJ.PIONOWO(B22;$B$12:$C$14;2;0));WYSZUKAJ.PIONOWO(B22;$B$12:$D$14;3;0);0)


Wyszukaj pionowa ze zmiennym zakresem.xlsx
Pobierz Plik ściągnięto 12 raz(y) 9.08 KB

ID posta: 312087 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum


Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.