Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63742 Skopiuj do schowka Wyszukaj pionowo do pierwszej 1
Autor Wiadomość
Barnard33
Starszy Forumowicz


Posty: 32
Wysłany: 09-01-2019, 10:26   Wyszukaj pionowo do pierwszej 1

Proszę o pomoc w napisaniu formuły, która powinna zastępować rozbudową formułę zagnieżdżonego "jeżeli", wyszukując pionowo w dół aż do znalezienia "1".
Formuła w komórce C1, kopiowana w dół.

Jeżeli B11=1 to C1=A11
Jeżeli nie, szukaj niżej:
Jeżeli B12=1 to C1=A12
Jeżeli nie, szukaj niżej:
Jeżeli B13=1 to C1=A13
itd. przeszukując aż do B100. Jeżeli nadal "nie", to C1=A100 (ewentualnie jak się nie da to "fałsz")

Załączam przykład z przeszukaniem 3 wierszy dla C1. Chodzi o to, żeby 90 razy nie wpisywać jeżeli (i chyba excel tego nie dopuści).

Z góry dziękuję za pomoc.

wyszukaj pionowo do pierwszej 1.xlsx
Pobierz Plik ściągnięto 11 raz(y) 9.75 KB

ID posta: 360065 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2357 razy
Posty: 4008
Wysłany: 09-01-2019, 10:38   

Kod:
=JEŻELI.BŁĄD(INDEKS(A1:A100;PODAJ.POZYCJĘ(1;B1:B100;0));A100)
_________________
Pozdrawiam
Asia
ID posta: 360067 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 1164 razy
Posty: 3483
Wysłany: 09-01-2019, 11:54   

Trochę inaczej
Kod:
=JEŻELI.BŁĄD(ADRES(PODAJ.POZYCJĘ(1;B:B;0);2;4);"brak 1")
Pozdrawiam.
ID posta: 360075 Skopiuj do schowka
 
 
Barnard33
Starszy Forumowicz


Posty: 32
Wysłany: 09-01-2019, 15:43   

Dziękuję Wam.
ID posta: 360100 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe