Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 3029 Skopiuj do schowka Wypisywanie tekstu z osobnej zakładki co 10 wierszy
Autor Wiadomość
misiek008-85
[Usunięty]

Wysłany: 21-09-2007, 15:17   Wypisywanie tekstu z osobnej zakładki co 10 wierszy

Witam. Mam taki problem. Chcę żeby Excel mi wypisał co 10 pozycję z osobnej zakładki. Część to jest sam tekst a część to liczby i ogólne wartości. Jak można coś takiego zrobić?
ID posta: 15696 Skopiuj do schowka
 
 
Eltokar 
ExcelSpec


Pomógł: 175 razy
Posty: 313
Wysłany: 21-09-2007, 15:37   

Zakładając że chcesz dane z zakładki arkusz2 z kolumny A
Możesz to zrobić np tak:
w arkusz1 w a1 wpisz
Kod:
=INDEKS(Arkusz2!A:A;WIERSZ(A1)*10)
i przeciągnij w dół.
Przy czym
Kod:
WIERSZ(A1)*10
zmodyfikuj sobie wg swoich potrzeb tak, żeby 'dobrze wskazywało'
ID posta: 15702 Skopiuj do schowka
 
 
misiek008-85
[Usunięty]

Wysłany: 21-09-2007, 18:58   

Niestety to nie zawsze działa. Mam ok 4000 rekordów. Mnożąc wszystko przez 10 już nie wszystkie mi wypisuje. A czy nie dało by się zrobić coś takiego żeby wpisać taką formułę:
Kod:
=modele!B1
i w tym B1 byłby odnośnik do rekordu np A4 w tej samej zakładce modele, następnie B2 odnośnik do B14 i żeby odczytywało to z tych właśnie odnośników o 10 większych? Nie wiem czy dobrze wytłumaczyłem :-/ Dodaję plik jak to mniej więcej powinno wyglądać. No i dziękuję za poprzedni pomysł oczywiście.

Spis.rar
Pobierz Plik ściągnięto 146 raz(y) 52.71 KB

ID posta: 15719 Skopiuj do schowka
 
 
Trebor 
Excel Expert


Pomógł: 1752 razy
Posty: 4680
Wysłany: 21-09-2007, 19:31   

Pokombinuj jakoś tak (formuła dla pierwszego wiersza)
Kod:
=INDEKS(modele!B$1:B$4000;(WIERSZ(A1)-1)*10+1)


Hej
_________________
Trebbor@wp.pl
ID posta: 15722 Skopiuj do schowka
 
 
Eltokar 
ExcelSpec


Pomógł: 175 razy
Posty: 313
Wysłany: 21-09-2007, 20:32   

Jak sobie pooglądałem Twój spis to wyszło mi, że potrzebujesz czegoś takiego.
(Podobnie dla innych kolumn.)

Spis.zip
Pobierz Plik ściągnięto 140 raz(y) 50.77 KB

ID posta: 15724 Skopiuj do schowka
 
 
misiek008-85
[Usunięty]

Wysłany: 22-09-2007, 08:09   

Dzięki serdeczne. O to mi chodziło. Poprzednie też zadziałały.
ID posta: 15747 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe