Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64066 Skopiuj do schowka Wyliczanie nakładających się godzin
Autor Wiadomość
myshka 
forumowicz


Posty: 18
Wysłany: 07-02-2019, 15:36   Wyliczanie nakładających się godzin

Szukam formuły, która wyliczy mi sumę godzin, ale...

mam godziny:
8:00-9:45
9:10-12:01
10:30-14:25
15:00-18:00
15:45-16:00

I szukam formuły, która wyliczy mi czasy i wyjdzie mi:
8:00-14:25
15:00-18:00

łącznie 09:25 godziny
ID posta: 362141 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2369 razy
Posty: 4028
Wysłany: 07-02-2019, 17:17   

tablicowa
Kod:
=MAX.K(JEŻELI((LEWY(A1:A5;ZNAJDŹ("-";A1:A5)-1)*1>=CZAS.WARTOŚĆ("8:00"))*(LEWY($A$1:$A$5;ZNAJDŹ("-";A1:A5)-1)*1<CZAS.WARTOŚĆ("15:00"));PRAWY(A1:A5;DŁ(A1:A5)-ZNAJDŹ("-";A1:A5))*1;"");1)-MIN.K(JEŻELI((LEWY(A1:A5;ZNAJDŹ("-";A1:A5)-1)*1>=CZAS.WARTOŚĆ("8:00"))*(LEWY(A1:A5;ZNAJDŹ("-";A1:A5)-1)*1<CZAS.WARTOŚĆ("15:00"));LEWY(A1:A5;ZNAJDŹ("-";A1:A5)-1)*1;"");1)+MAX.K(JEŻELI((LEWY(A1:A5;ZNAJDŹ("-";A1:A5)-1)*1>=CZAS.WARTOŚĆ("15:00"));PRAWY(A1:A5;DŁ(A1:A5)-ZNAJDŹ("-";A1:A5))*1;"");1)-MIN.K(JEŻELI((LEWY(A1:A5;ZNAJDŹ("-";A1:A5)-1)*1>=CZAS.WARTOŚĆ("15:00"));LEWY(A1:A5;ZNAJDŹ("-";A1:A5)-1)*1;"");1)
_________________
Pozdrawiam
Asia
ID posta: 362147 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 1248 razy
Posty: 4291
Wysłany: 07-02-2019, 17:20   

Tymczasem, póki nikt nic lepszego nie proponuje, (edit: tymczasem Asia zaproponowała) wariant z kolumnami pomocniczymi, w którym czas przeliczamy na minuty, mnożąc przez 1440. Chodzi o to, żeby były liczby całkowite i w komórkach arkusza. Obszarowi temu nadałem nazwę minuty. Potem ta nazwa jest użyta do definicji innej nazwy num:
Kod:
=WIERSZ(INDEKS(Arkusz1!$A:$A;MIN(minuty)):INDEKS(Arkusz1!$A:$A;MAX(minuty)))
Wynik zwraca formuła:
Kod:
=SUMA.ILOCZYNÓW(--(LICZ.JEŻELI(INDEKS(minuty;;1);"<"&num)-LICZ.JEŻELI(INDEKS(minuty;;2);"<"&num)>0))/1440
zaznaczona na zielono.
W drugim pliku inna koncepcja rozwiązania znaleziona w Sieci (nie testowałem). Autor: Oscar Cronquist

Suma_nakł_czasu.xlsx
Pobierz Plik ściągnięto 14 raz(y) 9.56 KB

How-to-count-overlapping-timev3.xlsx
Pobierz Plik ściągnięto 11 raz(y) 15.3 KB

ID posta: 362149 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe