Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63699 Skopiuj do schowka Ten sam warunek dla zakresu "LUB"
Autor Wiadomość
fiku15 
Starszy Forumowicz


Posty: 39
Wysłany: 06-01-2019, 11:35   Ten sam warunek dla zakresu "LUB"

Witam.
Mam formułę:
Kod:
=JEŻELI(LUB(A1="TAK",A2="TAK",A3="TAK",A4="TAK"),"OK","NOK")

Czy istnieje możliwość zrobienia tak:
Kod:
LUB(A1:A4="TAK")

oczywiście powyższy myk nie działa;/ już długo z tym walczę a mam dużo szerszy zakres do zrobienia w funkcji LUB.
Proszę o pomoc
Pozdrawiam

Edit: Zefirek
Proszę stosować znaczniki [code] przy wstawianiu kodów makr, kwerend i formuł, Regulamin 3.1
_________________
:)
ID posta: 359796 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 335 razy
Posty: 1784
Wysłany: 06-01-2019, 12:00   

Kod:
=JEŻELI(LICZ.JEŻELI(A1:A4;"TAK")>0;"OK";"NOK")
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
I dbajmy - proszę - o poprawną polszczyznę.
ID posta: 359798 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 1286 razy
Posty: 4418
Wysłany: 07-01-2019, 10:53   

fiku15, Twoja formuła jest poprawna, tylko trzeba ją zatwierdzić tablicowo (przez Ctrl+Shift+Enter), albo przerobić tak, żeby tego nie wymagała np. dodając funkcję INDEKS. Formuła umiejeada jest o tyle lepsza, że nie wymaga zatwierdzenia tablicowego i jest odporna na błędy w zakresie danych.

czyOK.xlsx
Pobierz Plik ściągnięto 13 raz(y) 8.99 KB

ID posta: 359888 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe