Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70523 Skopiuj do schowka Sumy czasów i liczb dla danego zakresu dla tego typu danych
Autor Wiadomość
matiz17 
ExcelGaduła 500+


Wersja: Win Office 2019
Pomógł: 1 raz
Posty: 846
Wysłany: 27-03-2021, 01:47   Sumy czasów i liczb dla danego zakresu dla tego typu danych

W załączniku plik z arkuszem "Baza", gdzie zbieram dane oraz "Analiza", gdzie analizuję dane. Potrzebuję napisać formułę, która będzie uwzględniała wedle podanych dat (od - do, kolumna A i B w "Analiza") sumy czasów / liczb. Na żółto przykłady z formuł zrobionych ręcznie.
Czy da się to w jakiś sposób zrobić?

sumyczasowiliczbdlazakresudanych.xlsx
Pobierz Plik ściągnięto 8 raz(y) 18.1 KB

_________________
Matiz17
ID posta: 402798 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2770 razy
Posty: 4644
Wysłany: 27-03-2021, 10:34   

załącznik

sumyczasowiliczbdlazakresudanych (1).xlsx
Pobierz Plik ściągnięto 5 raz(y) 13.25 KB

_________________
Pozdrawiam
Asia
ID posta: 402822 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 2118 razy
Posty: 6628
Wysłany: 27-03-2021, 12:11   

Propozycja drobnej modyfikacji formuły Asi w kolumnie C, żeby uniknąć zatwierdzania tablicowego:
Kod:
=SUMA.ILOCZYNÓW((Baza!$B$2:$B$22>=A3)*(Baza!$B$2:$B$22<=B3)*N(+Baza!$T$2:$T$22))


sumyczasowiliczbdlazakresudanych (Asia).xlsx
Pobierz Plik ściągnięto 5 raz(y) 12.81 KB

ID posta: 402827 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1317 razy
Posty: 4544
Wysłany: 27-03-2021, 13:47   

Po prostu SUMA.WARUNKÓW

C3
Kod:

=SUMA.WARUNKÓW(Baza!$T$2:$T$22;Baza!$B$2:$B$22;">="&A3;Baza!$B$2:$B$22;"<="&B3;Baza!$T$2:$T$22;">=0")

E3
Kod:

=SUMA.WARUNKÓW(Baza!$H$2:$H$22;Baza!$B$2:$B$22;">="&A3;Baza!$B$2:$B$22;"<="&B3;Baza!$H$2:$H$22;">=0")
ID posta: 402830 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe