Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70212 Skopiuj do schowka sumowanie warunkowe zakresów z kilku arkuszy
Autor Wiadomość
zbysiomysio 
Exceloholic


Wersja: Win Office 2003
Posty: 213
Wysłany: 22-02-2021, 15:53   sumowanie warunkowe zakresów z kilku arkuszy

Mam formułę, która zlicza sumę komórek spełniających określony warunek występujących w wielu arkuszach. Zastosowałem w tym przypadku sumę funkcji SUMA.JEŻELI. Moja funkcja wygląda j.n.
Kod:
=SUMA.JEŻELI('1'!$A$4:$A$30;A4;'1'!$B$4:$B$30)+SUMA.JEŻELI('2'!$A$4:$A$30;A4;'2'!$B$4:$B$30)+...............+=SUMA.JEŻELI('99'!$A$4:$A$30;A4;'99'!$B$4:$B$30)

Czy jest możliwość wyznaczenia zakresu dla wszystkich arkuszy bez konieczności wymieniania kolejno wszystkich arkuszy. Jak taka funkcja powinna wyglądać?
ID posta: 400847 Skopiuj do schowka
 
 
kuma 
Excel Expert


Wersja: Win Office 2010
Pomógł: 1440 razy
Posty: 4108
Wysłany: 22-02-2021, 16:55   

Spróbuj tak.
Nadaj nazwę, np. ark (Menedżer nazw), która będzie się odnosić do nazw arkuszy, np. ={"Arkusz1";"Arkusz2"; itd}.
W arkuszu użyj formuły.
Kod:
=SUMA.ILOCZYNÓW(SUMA.JEŻELI(ADR.POŚR(ark&"!A:A");A4;ADR.POŚR(ark&"!B:B")))
Zamiast całych kolumn w formule możesz podać mniejszy zakres.
_________________
Pozdrawiam.
ID posta: 400852 Skopiuj do schowka
 
 
zbysiomysio 
Exceloholic


Wersja: Win Office 2003
Posty: 213
Wysłany: 22-02-2021, 17:20   

Dzięki wielkie :clap
  
ID posta: 400856 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe