Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64018 Skopiuj do schowka Suma Jeżeli nie zlicza
Autor Wiadomość
Wojtek01
forumowicz


Posty: 16
Wysłany: 03-02-2019, 11:43   Suma Jeżeli nie zlicza

Witam,
mam w arkuszu "Wpłaty" w kolumnach B2:F2 nazwy funduszy i pod nimi w wierszach odpowiednio wpłaty na ten fundusz. W arkuszu "Portfel" mam tabelkę z nazwami tych funduszy i obok w kolumnie zsumowaną wpłatę, ale nie zlicza mi się ona poprawnie, zlicza mi tylko pierwszy wiersz z wpłatą z arkusza "Wpłaty" poniższe wiersze są pomijane:

Kod:
=SUMA.JEŻELI(Wpłaty!$B$2:Wpłaty!$F$2;TEKST(Portfel!B3;"");Wpłaty!B3:B21)


Czyli powiedzmy że dla nazwy w tabelce gdzie mam wpisane tekstowo "Fundusz1" powinien mi zliczyć wpłaty od B3 do B21 w arkuszu "Wpłaty" a zlicza mi tylko wartość B3 niższe nie.
ID posta: 361853 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2435 razy
Posty: 4125
Wysłany: 03-02-2019, 12:05   

spróbuj taki
Kod:
=SUMA.JEŻELI(Wpłaty!B2:F2;Portfel!B3;Wpłaty!B3:B21)
_________________
Pozdrawiam
Asia
ID posta: 361854 Skopiuj do schowka
 
 
Wojtek01
forumowicz


Posty: 16
Wysłany: 03-02-2019, 15:05   

nic to nie zmieniło, liczy tylko pierwszy wiersz
ID posta: 361860 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2435 razy
Posty: 4125
Wysłany: 03-02-2019, 15:19   

Kod:
=SUMA.ILOCZYNÓW((Wpłaty!B2:F2=Portfel!B3)*(Wpłaty!B3:F21))

daj załącznik
_________________
Pozdrawiam
Asia
ID posta: 361862 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1236 razy
Posty: 4306
Wysłany: 03-02-2019, 15:20   

Człowieku, dołącz plik. Nikt nie wie, jaką masz strukturę danych w tych arkuszach. Mogę domyślać, ale nie ryzykuję.
Wg mnie po prostu SUMA(INDEKS+PODAJ.POZYCJĘ)
ID posta: 361863 Skopiuj do schowka
 
 
Wojtek01
forumowicz


Posty: 16
Wysłany: 06-02-2019, 18:35   

Asia_@. napisał/a:
Kod:
=SUMA.ILOCZYNÓW((Wpłaty!B2:F2=Portfel!B3)*(Wpłaty!B3:F21))

daj załącznik

ta regułka zadziałała. podziękowałem.
ID posta: 362084 Skopiuj do schowka
 
 
Wojtek01
forumowicz


Posty: 16
Wysłany: 18-06-2019, 16:41   

Cześć,
muszę zmodyfikować troszkę tą regułkę:
tzn jeśli dla wartości z pola B4 znajdzie taką samą w arkuszu "Wpłaty" w zakresie od B2:B40 oraz obok będzie występować wartość "Nabycie" wtedy policz wszystkie sumy w kolumnie D w zakresie D2:D40 (mam nadzieję że zrozumiałe), coś próbowałem zmienić ale nie liczy :-/ :

Kod:
=SUMA.ILOCZYNÓW((Wpłaty!B2:B40=Portfel!B4)ORAZ(Wpłaty!C2:C40;"Nabycie")*(Wpłaty!D2:D40))
ID posta: 369573 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe