Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 68564 Skopiuj do schowka Suma całego wiersza, ale numer wiersza jest zmienny
Autor Wiadomość
sasza5 
forumowicz


Wersja: Win Office 2010
Posty: 12
Wysłany: 21-07-2020, 16:12   Suma całego wiersza, ale numer wiersza jest zmienny

Witajcie

Potrzebuję pomocy w zastąpieniu numerów wiersza formułami, takimi by były rozumiane przez funkcję - Suma(22:22)

Numer wiersza to pozycja wystąpienia danego tekstu w kolumnie.

W załączeniu plik. Z góry dziękuję za pomoc.

pozdrawiam

Suma całego wiersza - numer wiersza zmienny.xlsx
Pobierz Plik ściągnięto 8 raz(y) 8.81 KB

ID posta: 389997 Skopiuj do schowka
 
 
Bill Szysz 
Excel Expert


Wersja: Win Office 365
Pomógł: 887 razy
Posty: 3583
Wysłany: 21-07-2020, 16:24   

W D11
Kod:
=SUMA(INDEKS(12:1000;PODAJ.POZYCJĘ(C11;D12:D1000;0);))

Dostosuj sobie zakresy jeśli potrzebujesz.
Powyższa formuła zakłada, że w C11 masz tekst "ABC" (czy inny szukany)
_________________
Zlecenia, konsultacje, doradztwo i szkolenia z Power Query, Power BI i Excela - Raporty, Analizy, Projekty
Pozdrawiam, były szbill62 aktualnie Bill Szysz
ID posta: 389998 Skopiuj do schowka
 
 
sasza5 
forumowicz


Wersja: Win Office 2010
Posty: 12
Wysłany: 21-07-2020, 16:44   

Super, dziękuję bardzo. Właśnie o to chodziło :)
Z ciekawości, gdyby kiedyś była potrzeba by zakres tablicy był też zmienny (przy wielu tysiącach rekordów) to jest opcja by to 1000 też zastąpić jakąś formułą, która będzie zwracała numer ostatniego niepustego wiersza?
ID posta: 390001 Skopiuj do schowka
 
 
Bill Szysz 
Excel Expert


Wersja: Win Office 365
Pomógł: 887 razy
Posty: 3583
Wysłany: 21-07-2020, 17:07   

sasza5, w Twoim przypadku nie warto dynamicznie ustalać pozycję ostatniego wiersza (ale oczywiście da się to zrobić). Po prostu zastąp już teraz liczbę 1000 przez spodziewaną największą ilość wierszy (np 50 000).
Dla zaspokojenia Twojej ciekawości - poniższa formuła ustala ostatni wiersz w kolumnie D w którym cokolwiek wpisano (wpis ma być tekstem a nie liczbą)
Kod:
=PODAJ.POZYCJĘ("zzzzz";D:D;1)
_________________
Zlecenia, konsultacje, doradztwo i szkolenia z Power Query, Power BI i Excela - Raporty, Analizy, Projekty
Pozdrawiam, były szbill62 aktualnie Bill Szysz
ID posta: 390002 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe