Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 55476 Skopiuj do schowka Przeciąganie formuły co 7 komórek
Autor Wiadomość
szafa156
forumowicz


Posty: 12
Wysłany: 04-01-2017, 18:12   Przeciąganie formuły co 7 komórek

Witam, mam tabele z danymi od lipca do nowego roku. Teraz chciałbym policzyć sobie średnie tygodniowe. Od poniedziałku do niedzieli, niestety wpisanie średniej i przesunięcie jej w bok powoduje, że 2 średnia jest od wtorku do poniedziałku.

Chodzi o przesuwanie formuły co 7 pól.
ID posta: 312080 Skopiuj do schowka
 
 
marzatela 
Excel Expert



Zaproszone osoby: 254
Pomogła: 391 razy
Posty: 2202
Wysłany: 04-01-2017, 18:21   

A może tak załącznik z przykładowymi danymi?
_________________
marzatela

http://www.szultaset.pl
ID posta: 312085 Skopiuj do schowka
 
 
szafa156
forumowicz


Posty: 12
Wysłany: 04-01-2017, 18:36   

O sorki;/ już wstawiam

Nowy Arkusz programu Microsoft Excel.xlsx
Pobierz Plik ściągnięto 17 raz(y) 9.86 KB

ID posta: 312090 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 960 razy
Posty: 3354
Wysłany: 04-01-2017, 21:35   

formuła dla B10
Kod:

=ŚREDNIA(PRZESUNIĘCIE($B2:$H2;;7*(LICZBA.KOLUMN($A$1:A$1)-1)))

przeciągnij w prawo i w dół
ID posta: 312099 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 789 razy
Posty: 2498
Wysłany: 05-01-2017, 09:39   

U mnie bez funkcji ulotnych. W 'B10' i kopia w prawo i w dół
Kod:
=JEŻELI.BŁĄD(ŚREDNIA(INDEKS($B2:$CA2;;7*LICZBA.KOLUMN($B$2:B$2)-6):INDEKS($B2:$CA2;;7*LICZBA.KOLUMN($B$2:B$2)));"")
Pozdrawiam.
ID posta: 312145 Skopiuj do schowka
 
 
Czeslaw
ExcelSpec


Pomógł: 110 razy
Posty: 418
Wysłany: 05-01-2017, 14:33   

Moja propozycja w załączniku

Nowy Arkusz programu Microsoft Excel-2.xlsx
Pobierz Plik ściągnięto 25 raz(y) 11.11 KB

ID posta: 312211 Skopiuj do schowka
 
 
szafa156
forumowicz


Posty: 12
Wysłany: 07-01-2017, 08:37   

Super, dziękuję uprzejmie. Najbardziej zrozumiała dla mnie wersja apollo. Wielki plus dla Was.
ID posta: 312372 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum


Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.