Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 61153 Skopiuj do schowka Problem z średnią
Autor Wiadomość
adamtg 
Fan Excela


Posty: 70
Wysłany: 18-04-2018, 10:44   Problem z średnią

Witam,

Mam problem z stworzeniem formuły do wyliczania średniej.

Chciałbym aby wyciagać średnią z Kolumny D tak aby:
- wyliczała średnią wzgledem pojawienia się danych w kolumnie C - czyli jezeli mamy A i B to wylicza śrenia tylko dla tych 2 wierszy jezeli tylko A to dla jednego jeżeli A B i C to dla 3 wierszy
- jezeli komórki w kolumnie D puste to podsumowanie powinno pokazywać pusta komórke

Będę wdziecxzny za pomoc!

W załączeniu plik

Test - 3.xlsx
Pobierz Plik ściągnięto 14 raz(y) 9.31 KB

ID posta: 344621 Skopiuj do schowka
 
 
xfish
Exceloholic



Pomógł: 44 razy
Posty: 212
Wysłany: 18-04-2018, 10:53   

Przecież Twoja formuła działa.
Dodaj tylko warunek gdy puste. Czyli cos takiego:
Kod:
=JEŻELI.BŁĄD(ŚREDNIA.A(D7:D9);"")
ID posta: 344623 Skopiuj do schowka
 
 
adamtg 
Fan Excela


Posty: 70
Wysłany: 18-04-2018, 10:57   

Tak ale niewiem jak wrzucic warunek że jezeli np w wierszu 9 mamy puste pole to formuła i tak przeliczy średnią. Czyli Np
A - 10%
B - 12%
C - (pusta komórka)

Średnia - 7,33%
ID posta: 344626 Skopiuj do schowka
 
 
Bill Szysz 
Excel Expert


Pomógł: 736 razy
Posty: 3112
Wysłany: 18-04-2018, 11:26   

hmm... a zwykła ŚREDNIA ci nie wystarczy?
Kod:
=ŚREDNIA(D7:D9)

albo
Kod:
=ŚREDNIA.WARUNKÓW(D7:D9;D7:D9;"<>0")
_________________
Szkolenia z Power Query!!!

Pozdrawiam, były szbill62 aktualnie Bill Szysz
ID posta: 344634 Skopiuj do schowka
 
 
adamtg 
Fan Excela


Posty: 70
Wysłany: 18-04-2018, 15:01   

No własnie nie za bardzo ponieważ jeżeli popatrzysz na to przez pryzmat zmiany produkcyjnej i postojów. Jezeli mamy 3 zmiany produkcyjne A, B i C i na zmianie:
A - miałeś 10 min postoju
B - 20 min postoju
C - 0 min postoju (ale tu moze pojawiac się poprostu pusta komórka

gdzie wpisanie do kolumny symbolu A, B i C określa nam ilość zmian - moze nam dać 2 rózne wyniki.
Interesuje mnie to aby po symbolu A, B i C okreslic ile faktycznie zmian się odbyło.
Zwykła srednia nie policzy nam średniej z uwzględnieniem np tej jednej pustej komórcki z symbolu C a faktycznie powinna ona być brana pod uwage.
ID posta: 344656 Skopiuj do schowka
 
 
Kaper 



Zaproszone osoby: 3
Pomógł: 3622 razy
Posty: 7154
Wysłany: 18-04-2018, 17:08   

Jak dla mnie opis nieoczywisty. Zwłaszcza, że przykład wyniku jest tylko jeden - w poście 344626. No OK, może dwa, bo kiedy wszystkie 3 komórki wypełnione to normalna średnia.

Moja propozycja (może ciut na wyrost):
Kod:
=JEŻELI(ILE.LICZB(D7:D9)=0;"";SUMA(D7:D9)/ILE.NIEPUSTYCH(C7:C9))
_________________
Kaper Jej Królewskiej Mości :boss

Cytując bodka: "Sprowadzanie kłopotów do rangi nierozwiązywalnych problemów lub wręcz zakazów (nie tędy droga=czarna lista) pod szyldem jakiegoś tam ISO... to po prostu oszustwo."
ID posta: 344672 Skopiuj do schowka
 
 
Maciej Gonet
Excel Expert


Pomógł: 1045 razy
Posty: 3548
Wysłany: 18-04-2018, 17:37   

Piszesz tak, że nie wiadomo, czy chcesz, żeby puste komórki były pomijane, czy liczone jak 0.
W załączniku 4 warianty, w zależności od oczekiwanego wyniku.

Test - 3.xlsx
Pobierz Plik ściągnięto 8 raz(y) 9.64 KB

ID posta: 344675 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe