Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70207 Skopiuj do schowka Problem z dodaniem kolejnego wiersza tabeli
Autor Wiadomość
kogutor 
Świeżak


Wersja: Win Office 2016
Posty: 6
Wysłany: 21-02-2021, 17:04   Problem z dodaniem kolejnego wiersza tabeli

Witam,
czy może mi ktoś wskazać w jaki sposób mogę dodać kolejny wiersz w tabeli aby po odznaczeniu kontrolki dane wydrukowały się na kopercie jak w przypadku 38 wierszy powyżej tego testowego? W załączonym przykładzie dodałem ostatni wiersz , który niestety nie działa. Szukałem również w kodzie VBA problemu ale również bez skutku.

DRUKOWANIE KOPERT - SKLEPY (2).xlsm
Pobierz Plik ściągnięto 18 raz(y) 32.3 KB

ID posta: 400803 Skopiuj do schowka
 
 
Waldek 
Excel Expert


Wersja: Win Office 2019
Pomógł: 294 razy
Posty: 1300
Wysłany: 21-02-2021, 21:41   

Tak na szybko bez sprawdzania: w arkuszu SKLEPY w komórce C3 masz:
Kod:
=SUMA(C5:C38)

powinieneś rozszerzyć zakres.
ID posta: 400814 Skopiuj do schowka
 
 
Tadek
Excel Expert


Wersja: Win Office 2007
Pomógł: 1949 razy
Posty: 5587
Wysłany: 22-02-2021, 08:59   

W C3 wstaw formułę:
Kod:
=SUMA(PRZESUNIĘCIE($C$5;;;ILE.NIEPUSTYCH(SKLEPY!$B:$B)-1))
ID posta: 400824 Skopiuj do schowka
 
 
kogutor 
Świeżak


Wersja: Win Office 2016
Posty: 6
Wysłany: 22-02-2021, 10:56   

Dziękuję wam za pomoc :-D , oczywiście oba przykłady działają.
ID posta: 400829 Skopiuj do schowka
 
 
Waldek 
Excel Expert


Wersja: Win Office 2019
Pomógł: 294 razy
Posty: 1300
Wysłany: 22-02-2021, 12:28   

Gdy używasz VBA to te pomocnicze formuły w arkuszu nie są potrzebne. Można funkcje arkuszowe wywołać bezpośrednio w VBA bez zapisywania w arkuszu. Podam przykład zastosowania funkcji LICZ.JEŻELI dla kolumny B:
Kod:
    If Application.WorksheetFunction.CountIf(Range("B:B"), True) = 0 Then
       
        MsgBox ("Nie zaznaczono żadnego ze sklepów")
       
        Exit Sub
       
    End If

Podobnie funkcję arkuszową LICZ.JEŻELI można zastosować do określenia ilości wierszy:
Kod:
For wiersz = 5 To Application.WorksheetFunction.CountIf(Range("B:B"), True) + Application.WorksheetFunction.CountIf(Range("B:B"), False) + 4
If Sheets("SKLEPY").Cells(wiersz, 2) = True Then
Sheets("FORMAT").Cells(13, 8) = Sheets("SKLEPY").Cells(wiersz, 4)
Sheets("FORMAT").Cells(14, 8) = Sheets("SKLEPY").Cells(wiersz, 5)
Sheets("FORMAT").Cells(15, 8) = Sheets("SKLEPY").Cells(wiersz, 6)
Sheets("FORMAT").Cells(16, 8) = Sheets("SKLEPY").Cells(wiersz, 7)
Sheets("FORMAT").PrintOut
End If
Next
End Sub
  
ID posta: 400831 Skopiuj do schowka
 
 
Tadek
Excel Expert


Wersja: Win Office 2007
Pomógł: 1949 razy
Posty: 5587
Wysłany: 23-02-2021, 09:20   

Bez kolumny pomocniczej C można tak:
Kod:
Sub drukowanie_kopert_z_adresami()
Dim ost&, i&, ile&
Dim sh As Worksheet
Dim odp As Variant
Set shF = Worksheets("FORMAT")

With Sheets("SKLEPY")
        ost = .Cells(Rows.Count, "B").End(xlUp).Row
        ile = Application.CountIf(.Range("B5:B" & ost), True)
        If ile = 0 Then
            MsgBox "Nie zaznaczono żadnego ze sklepów!", vbInformation, "Informacja"
            Exit Sub
        End If
    For i = 5 To ost
        If .Cells(i, 2) = True Then
            shF.Cells(13, 8) = .Cells(i, 4).Value
            shF.Cells(14, 8) = .Cells(i, 5).Value
            shF.Cells(15, 8) = .Cells(i, 6).Value
            shF.Cells(16, 8) = .Cells(i, 7).Value
            Exit For
        End If
    Next
End With

        shF.PageSetup.PrintArea = "$A$1:$K$19"
        odp = Application.Dialogs(xlDialogPrinterSetup).Show
        If odp = True Then shF.PrintOut
End Sub
Zobacz w załączniku.

DRUKOWANIE KOPERT - SKLEPY (3).xlsm
Pobierz Plik ściągnięto 3 raz(y) 22.87 KB

ID posta: 400870 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe