Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63671 Skopiuj do schowka Poprawna treść funkcji
Autor Wiadomość
Machu1989 
świeżak


Posty: 1
Wysłany: 03-01-2019, 21:52   Poprawna treść funkcji

Witam potrzebuję użyć połączonej funkcji "JEŻELI" oraz "TRANSPONUJ" ale niestety nie mogę jej opanować, czy taka taka zależność dla kilku różnych wartości "JEŻELI" będzie działać??

Przykład:
Kod:
=JEŻELI(A1="TREŚĆ1";TRANSPONUJ('BAZA DANYCH'.D3:K5));JEŻELI(A1="TREŚĆ2";TRANSPONUJ('BAZA DANYCH'.D8:K10))


Edit: mkkk23
Przy wpisywaniu kodów makr lub formuł używaj znaczników [code] (zgodnie z pkt. 3.1 Regulaminu naszego forum).
_________________
Damian
ID posta: 359605 Skopiuj do schowka
 
 
DwaNiedźwiedzie 
Excel Expert



Pomógł: 217 razy
Posty: 555
Wysłany: 04-01-2019, 08:36   

Przy odnoszeniu się do innego arkusza użyłeś kropki zamiast wykrzyknika i dodałeś niepotrzebnie nawias po pierwszym TRANSPONUJ (zamknąłeś JEŻELI po pierwszym argumencie). Dodatkowo w takiej postaci formuła zwróci FAŁSZ, jeżeli w A1 będzie inna wartość niż TREŚĆ1 lub TREŚĆ2, możesz dodać obsługę takiego przypadku przed drugim nawiasem od końca:
Kod:
=JEŻELI(A1="TREŚĆ1";TRANSPONUJ('BAZA DANYCH'!D3:K5);JEŻELI(A1="TREŚĆ2";TRANSPONUJ('BAZA DANYCH'!D8:K10);"bd"))

Formuła oczywiście jest tablicowa, czyli zatwierdzana przez control+shift+enter.
ID posta: 359637 Skopiuj do schowka
 
 
xfish 
ExcelSpec



Wersja: Win Office 2013
Pomógł: 145 razy
Posty: 560
Wysłany: 04-01-2019, 08:38   

Oczywiście funkcja Jeżeli w połączeniu z Transponuj będzie działać (pamiętaj o zatwierdzeniu poprzez Ctrl,Shift,Enter).
Zrób najpierw działające funkcje Transponuj a później wrzuć je do funkcji Jeżeli.
U ciebie coś mi nie pasuje z zakresem, który chcesz transponować.
Co to jest 'Baza danych'? Plik, Arkusz, Nazwa?
ID posta: 359638 Skopiuj do schowka
 
 
z-kes 
Stały bywalec Excelforum


Pomógł: 29 razy
Posty: 433
Wysłany: 04-01-2019, 20:29   

xfish napisał/a:
(pamiętaj o zatwierdzeniu poprzez Ctrl,Shift,Enter).


i prawdopodobnie :hamer pamiętaj Machu1989, aby przed wpisaniem czegokolwiek zaznaczyć tyle komórek (wierszy tyle co kolumn i kolumn tyle co wierszy) ile jest w zakresach TRANSPONUJ.
1. Zaznacz
2. Wpisz formułę
3. Wciśnij CSE

Pozdrawiam
D.
ID posta: 359701 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe