Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63706 Skopiuj do schowka Odczyt informacji ze zbiorczego pliku dla danego miesiąca
Autor Wiadomość
Krzych1960 
świeżak


Posty: 7
Wysłany: 07-01-2019, 00:22   Odczyt informacji ze zbiorczego pliku dla danego miesiąca

Witam !
Mam problem jaką formułę.
Chodzi mi o formułę wyciągającą numer z kolumny C (Numer w kolumnie C jest automatycznie przypisywany po wpisaniu wartości do kolumny D.) pliku Firma2019.xlsm i wstawienie tego numeru do pliku DZ-Styczeń.xlsx bądź do pliku DZ-Luty.xlsx w zależności od miesiąca. Np. wpisujemy wartość 333 do kolumny D Styczeń-2019, w kolumnie C pojawia się wartość 1, teraz ta jedynka powinna się pojawić również w komórce I6 Dziennego zestawienia01 – Styczeń.xlsx.. Następnie wpisujemy następną wartość do kolumny a wkolumnie C pojawia się wartość 2 która powinna pojawić się również komórce T6 itd.

Firma2019.xlsm
Pobierz Plik ściągnięto 6 raz(y) 32.29 KB

DZ-Styczeń.xlsx
Pobierz Plik ściągnięto 5 raz(y) 50.05 KB

DZ-Luty.xlsx
Pobierz Plik ściągnięto 4 raz(y) 49.79 KB

ID posta: 359872 Skopiuj do schowka
 
 
Kaper 



Zaproszone osoby: 3
Pomógł: 3710 razy
Posty: 7388
Wysłany: 07-01-2019, 12:26   

Odpowiadając wprost na Twoje pytanie: np. dla T6:
Kod:
=JEŻELI(MAX([Firma2019.xlsm]DOCHODY!$C$3:$C$33)>=2;I6+1;"")


Albo; co przyda się przy kolejnch miesiącach; nadamy nazwę styczeń zakresowi $C$3:$C$33 (Ctrl+F3 ale widzę, że jest już sporo nazw podefiniowanych, więc znasz to)
Kod:
=JEŻELI(MAX(Firma2019.xlsm!styczeń)>=2;I6+1;"")

wtedy nazwa luty to C36:C63 i formuła dla I6 w DZ-luty:
Kod:
=JEŻELI(ILE.LICZB(Firma2019.xlsm!luty)>=1;MAX.K(Firma2019.xlsm!luty;1);"")
a dla T6 (w DZ_luty):
Kod:
=JEŻELI(ILE.LICZB(Firma2019.xlsm!luty)>=2;MIN.K(Firma2019.xlsm!luty;2);"")
itd

A teraz obok:
Proponuję przyjrzeć się funcjonalności "Korespondencja seryjna" w Wordzie (Jako typ tworzonego dokumentu zapewne najwygodniej będzie wykorzystać katalog, ew. etykiety). Dane źródłowe do tej korespondencji będzie znacznie łatwiej przygotować niż pracowicie uzupełniać formuły w takich plikach jak DZ-Styczeń itd.

I administracyjnie:
Zmieniłem tytuł Twojego posta (był: "Jaką formułę zastosować"), tak, żeby spełniał wymagania naszego http://www.excelforum.pl/regulamin.htm Proszę zapoznaj się z nim i stosuj.

Pozdrawiam,

DZ-Styczeń.xlsx
Pobierz Plik ściągnięto 2 raz(y) 45.44 KB

DZ-Luty.xlsx
Pobierz Plik ściągnięto 2 raz(y) 45.33 KB

Firma2019.xlsm
Pobierz Plik ściągnięto 3 raz(y) 21.36 KB

_________________
Kaper Jej Królewskiej Mości :boss

Jestem leniwy, ale się staram
ID posta: 359902 Skopiuj do schowka
 
 
Krzych1960 
świeżak


Posty: 7
Wysłany: 07-01-2019, 15:33   

Dzięki opdpowiedź okazała się pomocna.
Temat można zamknąć.
ID posta: 359916 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe