Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64015 Skopiuj do schowka Nieobowiązkowy argument drugi w funkcji Jeżeli
Autor Wiadomość
WicherTKD
Stały bywalec Excelforum


Pomógł: 18 razy
Posty: 406
Wysłany: 02-02-2019, 16:20   Nieobowiązkowy argument drugi w funkcji Jeżeli

Czy może mi ktoś wytłumaczyć, dlaczego MS w drugim argumencie funkcji Jeżeli daje nawiasy kwadratowe? Wpisuje =Jeżeli(A1="Pomidor") i funkcja zwraca błąd za mało argumentów, natomiast podczas wprowadzanie niby jest nieobowiązkowy i powinien zwracać wartość True lub False dokładnie tak samo jakby wpisał =A1="Pomidor"

Przygotowuję się do szkoleń i muszę być konsekwentny. Albo nawiasy kwadratowe oznaczają argumenty nieobowiązkowe i nie muszę ich podawać albo jest obowiązkowy.Czy to błąd?

Podałem Excelowi 3 argument bez 2 i działa czyli oba są nieobowiązkowe ale jeden muszę podać, ale wynik zamiast PRAWDY jest na 0 (Fałsz). Czy ktoś już się tym zainteresował wcześniej?

51270202_2362131040486047_7104170855873118208_n.jpg
Plik ściągnięto 162 raz(y) 6.05 KB

2.PNG
Plik ściągnięto 162 raz(y) 5.99 KB

_________________
Budżet w Excelu (BWE)
ID posta: 361831 Skopiuj do schowka
 
 
Tajan


Pomógł: 4309 razy
Posty: 9583
Wysłany: 02-02-2019, 18:33   

Przecież to wszystko masz w helpie. Możesz nie podać dwóch argumentów:
Kod:
=JEŻELI(A1="pomidor";;)
wtedy funkcja zawsze zwraca 0. Natomiast, jeżeli zrobisz to tak:
Kod:
=JEŻELI(A1="pomidor";)
to przy spełnionym warunku zostanie zwrócone 0, a przy niespełnionym - FAŁSZ. Działanie funkcji w żadnym przypadku nie przewiduje zwrotu wartości PRAWDA przy braku argumentu.
ID posta: 361835 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 1248 razy
Posty: 4291
Wysłany: 04-02-2019, 13:34   

Ode mnie w załączniku jeszcze nieco więcej o funkcji JEŻELI. Problem argumentów obowiązkowych i opcjonalnych w Excelu jest dość złożony i w helpie jest to czasem nieprecyzyjnie podane. Rzecz w tym, że jeśli funkcja ma więcej niż jeden argument obowiązkowy (ale nie odwołaniowy), to jego wartość można mimo to pominąć, ale trzeba pozostawić średniki. Taki pominięty argument jest argumentem pustym i funkcja przyjmuje wtedy zawsze jego wartość jako 0, FAŁSZ lub tekst pusty, zależnie jakiego rodzaju wartości oczekuje. Natomiast jeśli funkcja ma argument opcjonalny, to znaczy, że można go pominąć wraz z poprzedzającym średnikiem i wtedy przyjmuje on wartość domyślną, określoną w opisie funkcji.
Kilka przykładów. Funkcja LOG ma pierwszy argument obowiązkowy, a drugi opcjonalny o wartości domyślnej 10. Prawidłowe jest zatem użycie:
Kod:
LOG(5;2) lub LOG(5), a nieprawidłowe LOG(5;)
bo drugi argument miałby tu wartość 0, a to jest niepoprawne.
Funkcja ADR.POŚR ma pierwszy argument obowiązkowy, a drugi opcjonalny o wartości domyślnej PRAWDA. Prawidłowe jest więc użycie:
Kod:
ADR.POŚR("A1") lub ADR.POŚR("W1K1";)

Użycie drugiego argumentu pustego powoduje, że przyjmuje on wartość FAŁSZ.
Funkcja CZAS ma 3 argumenty obowiązkowe, ale można jej użyć tak:
Kod:
CZAS(;;), co jest tożsame z użyciem CZAS(0;0;0)


O_funkcji_JEŻELI.docx
Pobierz Plik ściągnięto 11 raz(y) 14.47 KB

ID posta: 361918 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe