Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64288 Skopiuj do schowka Losowanie bez powtórzeń w stosunku do poprzedniego losowania
Autor Wiadomość
Imperterritus
świeżak


Posty: 2
Wysłany: 28-02-2019, 12:08   Losowanie bez powtórzeń w stosunku do poprzedniego losowania

Witam

Jak w temacie - chciałbym zrobić losowanie, które uwzględniałoby wyniki poprzedniego losowania.

Zamysłem całego zadania jest przyporządkowanie pracowników do zadań z zamysłem, aby przez 2 tygodnie z rzędu nie byli przypisani do tych samych zadań.

Obecnie wygląda to w ten sposób (załącznik).

Gdzie:
- komórki szare to wartości stałe
- komórki J3:J11 zawiera formułę
Kod:
los()

- komórki N3:N8 zawierają formułę
Kod:
=INDEKS(I3:I11;PODAJ.POZYCJĘ(MAX.K(J3:J11;M3);J3:J11;0);0)
z dynamiczną wartością M3
- tabelka H14:J20 pokazuje jakie osoby były w poprzednim tygodniu, J15:J20 ta sama formuła co N3:N8
- komórka B3:
Kod:
jeżeli(A3=I15;2;1)


Stworzyłem tabelę A2:G11 gdzie 1 to wartość: osoba nie była przypisana do danego zadania, 2 to wartość: był przypisany (lub jeżeli na szaro, to nie może być przypisany do danego zadania).
Próbowałem stworzyć formułę z dynamicznym zakresem, gdzie przykładowo formuła losująca brałaby pod uwagę osoby tylko z przypisaną wartością 1, ale niestety przerosło to moje umiejętności.

Stąd prośba o pomoc :)

Gdyby coś było niejasne, proszę o pytania.

Pozdrawiam
Imperterritus

excel.PNG
Plik ściągnięto 49 raz(y) 22.64 KB

ID posta: 363423 Skopiuj do schowka
 
 
Kaper 



Zaproszone osoby: 3
Wersja: Win Office 2016
Pomógł: 3712 razy
Posty: 7394
Wysłany: 08-03-2019, 13:21   

Proponuję załączyć nie obrazek, tylko przykładowy plik. Nie sądzę, żeby komuś chciało się "przeklepywać" dane z obrazka. Patrz wpis w naszym FAQ: http://www.excelforum.pl/...ika-vt59262.htm
_________________
Kaper Jej Królewskiej Mości :boss

Jestem leniwy, ale się staram
ID posta: 363859 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe