Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 3162 Skopiuj do schowka lista która wypisze kilka komórek
Autor Wiadomość
luzrak04
[Usunięty]

Wysłany: 30-09-2007, 00:55   lista która wypisze kilka komórek

witam, chciałbym w moim dokumencie umieścić listę w której byłyby nazwy firm i klientów mojego ojca. Dotychczas musi on wpisywać od nowa nazwę firmy nip adres itp.

Chciałbym umieścić tam listę. Po wybraniu z listy nazwę firmy np BudKom wypisałyby się w określonych komorkach adres nip i nazwa firmy. Jak to zrobić

wiem jak zrobić liste ale jak powiązać to z danymi?

[lista] ... ... ...
po wyborze
BudKom Kołobrzeg 49299492

thx
ID posta: 16468 Skopiuj do schowka
 
 
Blueinferno 
Fan Excela



Pomógł: 22 razy
Posty: 87
Wysłany: 30-09-2007, 02:06   

Zakładając, że nazwę firmy wybierasz z listy w komórce A1, a dane są w komórkach A2:C100, w B1 możesz wpisać:
Kod:

=JEŻELI(CZY.BŁĄD(WYSZUKAJ.PIONOWO($A$1;$A$2:$C$100;2;FAŁSZ));"";
WYSZUKAJ.PIONOWO($A$1;$A$2:$C$100;2;FAŁSZ))


Zwróci to wartość z drugiej kolumny zakresu danych. Czyli jeśli w A masz nazwę firmy, a w B miasto, to powyższa formuła zwróci nazwę miasta danej firmy.
W C1 wpisz:
Kod:

=JEŻELI(CZY.BŁĄD(WYSZUKAJ.PIONOWO($A$1;$A$2:$C$100;3;FAŁSZ));"";
WYSZUKAJ.PIONOWO($A$1;$A$2:$C$100;3;FAŁSZ))


itd. (liczby w funkcji WYSZUKAJ.PIONOWO wzrastają o 1)

Mam nadzieję, że o to chodziło.
ID posta: 16470 Skopiuj do schowka
 
 
luzrak04
[Usunięty]

Wysłany: 30-09-2007, 23:44   problem rozwiazany

JEŻELI(CZY.BŁĄD(INDEKS(baza;PODAJ.POZYCJĘ(nazwanabywcy;dostawca;0);2));"";
INDEKS(baza;PODAJ.POZYCJĘ(nazwanabywcy;dostawca;0);2))

chodzilo mi o cos takiego thx

pozdrawiam
ID posta: 16518 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe