Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 53185 Skopiuj do schowka Liczenie dni w miesiącu - problem z funkcją licz jeżeli
Autor Wiadomość
kuma 
Excel Expert


Pomógł: 748 razy
Posty: 2414
Wysłany: 19-12-2016, 17:12   

Tak jak napisałem, "nadmiarowe" dni w wierszu 2 ($B$2:$AF$2), w danym miesiącu, powinny być puste (możesz to przecież zautomatyzować!). W załączniku nie było "data od", ale dopisanie w formule tego warunku nie powinno sprawić Ci kłopotu.
Pozdrawiam.
ID posta: 310986 Skopiuj do schowka
 
 
aloyzz
świeżak


Posty: 9
Wysłany: 02-01-2017, 15:45   

Witam ponownie. z formułkami w formatowaniu warunkowym poradziłem sobie. ale z pierwszym problemem mimo wielu prób i spędzonego czasu nie jestem w stanie sobie poradzić. Tą formułę tablicową zaproponowaną powyżej nie bardzo umiem przerobić.

Załączam poprawiony plik z objaśnieniami.

Tabela (2).xlsx
Pobierz Plik ściągnięto 6 raz(y) 14.59 KB

ID posta: 311849 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 748 razy
Posty: 2414
Wysłany: 04-01-2017, 13:41   

Witaj w Nowym Roku. W 'AI4' wklej poniższą formułę tablicową z kopią w dół
Kod:
=JEŻELI($A4="codziennie";LICZ.JEŻELI(INDEKS($D4:$AH4;;PODAJ.POZYCJĘ(DZIEŃ(B4 );$D$2:$AH$2;0)):INDEKS($D4:$AH4;;PODAJ.POZYCJĘ(MAX($D$2:$AH$2);$D$2:$AH$2;0));"<>x");SUMA.ILOCZYNÓW(JEŻELI(JEŻELI.BŁĄD(ZNAJDŹ(INDEKS($D$3:$AH$3;;PODAJ.POZYCJĘ(DZIEŃ($B4 );$D$2:$AH$2;0)):INDEKS($D$3:$AH$3;;PODAJ.POZYCJĘ(MAX($D$2:$AH$2);$D$2:$AH$2;0));$A4);0);1;0)*(INDEKS($D4:$AH4;;PODAJ.POZYCJĘ(DZIEŃ($B4 );$D$2:$AH$2;0)):INDEKS($D4:$AH4;;PODAJ.POZYCJĘ(MAX($D$2:$AH$2);$D$2:$AH$2;0))<>"x")))
Pozdrawiam.
ID posta: 312020 Skopiuj do schowka
 
 
aloyzz
świeżak


Posty: 9
Wysłany: 04-01-2017, 17:11   

Witaj. Dziękuję za pomoc, teraz działa prawie idealnie.

Tylko ten fragment nie pasuje:

Kod:
PODAJ.POZYCJĘ(DZIEŃ(B4 );$D$2:$AH$2;0)


gdyż, niezależnie od miesiąca liczy zawsze od dnia podanego w kolumnie B. Kiedy data od będzie 7 grudnia 2016r. to w styczniu 2017r. formuła też liczy od 7 dnia. Podobnie z datą wsteczną, miesiąc może być np. styczeń 2017 a któraś z pozycji może być od 1 lutego 2017r.

Wrócę z pracy to pogłówkuje nad tym, może coś wymyślę, chociaż wątpię :)
ID posta: 312067 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum


Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.