Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 67594 Skopiuj do schowka Licz jeżeli z wiekiem
Autor Wiadomość
markustal
Exceloholic


Pomógł: 1 raz
Posty: 122
Wysłany: 20-03-2020, 13:32   Licz jeżeli z wiekiem

Witam,
Mam taki problem z wiekiem w funkcji licz jeżeli.
Z pesela wylicza mi wiek co do dnia w kolumnie F. Chcę policzyć ilość osób z 2 warunkami. Jak ma wyglądać formuła żeby policzyło ilość kobiet poniżej 18 lat oraz powyżej, To samo z Panami. Szukałem na forum, ale nie wiem co dodać do formuły która liczy mi ilość "płci".
W pierwszych wierszach pustych zostawiłem formuły, a dalej mam same wartości żeby nie podawać peseli.
Pozdrawiam

licz.jeżeli.xlsx
Pobierz Plik ściągnięto 25 raz(y) 12.75 KB

_________________
mm
ID posta: 384017 Skopiuj do schowka
 
 
xfish 
Excel Expert



Wersja: Win Office 2013
Pomógł: 336 razy
Posty: 1056
Wysłany: 20-03-2020, 14:29   

Dla Pani 18lat+
Kod:
SUMA.ILOCZYNÓW((DATA.RÓŻNICA(D5:D21;$C$24;"Y")>=18)*(E5:E21="Pani"))


dalej sobie poradzisz
_________________
Pozdrawiam
xFish
ID posta: 384022 Skopiuj do schowka
 
 
Waldek 
Excel Expert


Wersja: Win Office 2019
Pomógł: 238 razy
Posty: 1051
Wysłany: 20-03-2020, 15:39   

Formuła tablicowa w L23:
Kod:
=SUMA((E2:E21="Pani")*(D2:D21<=NR.SER.DATY(C24;18*-12)))

W L24:
Kod:
=SUMA((E2:E21="Pan")*(D2:D21<=NR.SER.DATY(C24;18*-12)))

W M23:
Kod:
=SUMA((E2:E21="Pani")*(N(D2:D21)>NR.SER.DATY(C24;18*-12)))

W M24:
Kod:
=SUMA((E2:E21="Pan")*(N(D2:D21)>NR.SER.DATY(C24;18*-12)))
ID posta: 384027 Skopiuj do schowka
 
 
markustal
Exceloholic


Pomógł: 1 raz
Posty: 122
Wysłany: 25-03-2020, 09:29   

Dziękuję, formuły jak najbardziej działają
Pozdrawiam
_________________
mm
ID posta: 384194 Skopiuj do schowka
 
 
markustal
Exceloholic


Pomógł: 1 raz
Posty: 122
Wysłany: 03-04-2020, 10:32   

Witam,
Jednak jest problem w obu propozycjach. Jeśli mam wpisane daty ręcznie działa ok. Ale jeśli wylicza z formuły - czyli pobiera z pesela wtedy błąd ARG wyskakuje. Funkcje są wpisane w pierwsze 3 komórki D i E. Co poprawić żeby to liczyło?
Pozdrawiam

Kopia licz.jeżeli-1.xlsx
Pobierz Plik ściągnięto 13 raz(y) 12.96 KB

_________________
mm
ID posta: 384836 Skopiuj do schowka
 
 
Waldek 
Excel Expert


Wersja: Win Office 2019
Pomógł: 238 razy
Posty: 1051
Wysłany: 03-04-2020, 10:54   

Jaką masz wersję Excela? U mnie formuła tablicowa działa. Najlepiej wersję wpisz w profil by od razu było wiadomo. W starych Excelach funkcja: NR.SER.DATY jest niedostępna. Funkcję: NR.SER.DATY zamień na funkcję: EDATE i jeszcze raz zatwierdź tablicowo.
ID posta: 384841 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2626 razy
Posty: 4430
Wysłany: 03-04-2020, 11:37   

tablicowe
Kod:
=SUMA((JEŻELI.BŁĄD(DATA.RÓŻNICA(D2:D21;$C$24;"Y");0)>=18)*(E2:E21="Pani"))

Kod:
=SUMA((E2:E21="Pani")*(JEŻELI.BŁĄD(D2:D21;0)<=NR.SER.DATY(C24;18*-12)))
_________________
Pozdrawiam
Asia
ID posta: 384847 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe