Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64446 Skopiuj do schowka jeżeli taka sama wartość to ...
Autor Wiadomość
markustal
Fan Excela


Pomógł: 1 raz
Posty: 66
Wysłany: 16-03-2019, 00:58   jeżeli taka sama wartość to ...

Witam,
Nie wiem jaką funkcję wpisać żeby zsumować tylko wtedy jeśli, wartość którejkolwiek komórce jest inna od pozostałych. W załączniku podałem dwie możliwości obliczenia ale nie wiem jak to zapisać. Jeśli ktoś ma chwilę to z góry dziękuję za pomoc.

takie same.xlsx
Pobierz Plik ściągnięto 15 raz(y) 9.69 KB

_________________
mm
ID posta: 364320 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 1275 razy
Posty: 4377
Wysłany: 16-03-2019, 09:10   

Warunkiem na sprawdzenie, czy liczby są identyczne (zakładam, że we wszystkich komórkach są liczby) jest równość maksimum i minimum, albo równość średniej arytmetycznej i geometrycznej (być może są i inne, ale te mi akurat przyszły do głowy).

takie same.xlsx
Pobierz Plik ściągnięto 25 raz(y) 9.84 KB

ID posta: 364327 Skopiuj do schowka
 
 
markustal
Fan Excela


Pomógł: 1 raz
Posty: 66
Wysłany: 19-03-2019, 19:42   

Dzięki Macieju,
Nie wpadłbym na takie rozwiązanie.
Jeszcze wymyśliłem inne, które przy niewielkiej ilości wierszy jest ok ale jeżeli mamy długi ciąg to Twoje jest super.
Moja propozycja to:
Kod:
=JEŻELI(ORAZ(B12=C12;C12=D12;D12=E12;E12=F12);"";SUMA(B12:F12))
_________________
mm
ID posta: 364571 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 1275 razy
Posty: 4377
Wysłany: 20-03-2019, 07:50   

Twoje rozwiązanie można też zapisać krócej jako:
Kod:
=JEŻELI(ORAZ(B12=C12:F12);"";SUMA(B12:F12))
ale to trzeba zatwierdzić tablicowo Ctrl+Shift+Enter. W tym przypadku długość ciągu jest praktycznie bez znaczenia.
ID posta: 364590 Skopiuj do schowka
 
 
markustal
Fan Excela


Pomógł: 1 raz
Posty: 66
Wysłany: 20-03-2019, 13:21   

No i jeszcze lepiej
Dzięki.
_________________
mm
ID posta: 364611 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe