Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
Przesunięty przez: Kaper
27-07-2020, 10:22
Jakiej formuły użyć, żeby ręcznie tego nie robić.
Autor Wiadomość
dmocha
forumowicz


Posty: 13
  Wysłany: 26-07-2020, 23:36   Jakiej formuły użyć, żeby ręcznie tego nie robić.

Cześć,

Jakiej formuły użyć, żeby ominąć potrzebę ręcznej modyfikacji istniejących formuł.

W swoim pliku pobieram dane przy użyciu MS Query.
Wynik kwerendy jest dynamiczny w zależności od wyboru miesiąca (komórka H1 arkusz 'stare').
Po prawej stronie wyniku kwerendy mam dodatkowe (szare) kolumny z formułami odnoszącymi się do odpowiedniej tabeli ('czerwiec', 'lipiec').
Jeśli chcę dokonać obliczeń dla lipca podmieniam ręcznie w formule czerwiec na lipiec (na potrzeby zobrazowania problemu celowo umieściłem dwa obramowane zakresy 'dynamiczne', jeden zawiera obliczenia dla czerwca drugi dla lipca).

Arkusz 'stare' zawiera:
Tabele 'czerwiec' i 'lipiec', dane w nich są statyczne, z nich pobierane są informację do szarych komórek z formułami.

Arkusz 'nowe' zawiera 'nowa_tabela' gdzie dodałem dwie żółte kolumny mc i rok.
Chciałbym tak zmodyfikować istniejące szare wzory, żeby pobierały się dane dla wybranego (komórka K1) miesiąca, a jeszcze lepiej gdyby dało się również uwzględnić rok.
Na przykład jeśli K1=7 to szukaj w zakresie: A22:H39
Do tabeli 'nowa_tabela' dopisywałbym kolejne dane statyczne, a wyborem miesiąca wskazywałbym odpowiednie dane źródłowe.

Wszystkie dane są "poglądowe".
Moich rzeczywistych danych jest dużo więcej.
Tabel takich jak 'czerwiec' i 'lipiec' jest więcej. W rzeczywistości zawierają poprzednie zakresy dat, a dane w nich są inne niż w kolejnych miesiącach, mogą się powtarzać, mogą być minimalnie różne lub zupełnie różne.

Nie mam pomysłu jak to zrobić. Potrzebuję formuł, nie interesują mnie makra, ani rozwiązania typu power pivot czy sam pivot.
Mam nadzieję, że jasno to opisałem. Będę wdzięczny za pomoc.

Używam Excela 365.

tab-wg-mca.xlsx
Plik z dwoma arkuszami, stare to dotychczasowy sposób, nowe to nowa pożądana tabela.
Pobierz Plik ściągnięto 7 raz(y) 27.37 KB

_________________
pozdrawiam
dmocha
ID posta: 390179 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2662 razy
Posty: 4478
Wysłany: 27-07-2020, 09:56   

w O4
Kod:
=INDEKS(nowa_tabela[flaga];PODAJ.POZYCJĘ(1;INDEKS(($J4=nowa_tabela[kolor])*($K4=nowa_tabela[nazwa])*(nowa_tabela[mc]=MIESIĄC(LEWY($J$1;ZNAJDŹ("'";$J$1)-1)&1))*(nowa_tabela[rok]=WARTOŚĆ(20&PRAWY($J$1;2)));0);0))

w P4
Kod:
=INDEKS(nowa_tabela[czas];PODAJ.POZYCJĘ(1;INDEKS(($J4=nowa_tabela[kolor])*($K4=nowa_tabela[nazwa])*(nowa_tabela[mc]=MIESIĄC(LEWY($J$1;ZNAJDŹ("'";$J$1)-1)&1))*(nowa_tabela[rok]=WARTOŚĆ(20&PRAWY($J$1;2)));0);0))

w R4
Kod:
=Q4*INDEKS(nowa_tabela[wartość];PODAJ.POZYCJĘ(1;INDEKS((J4=nowa_tabela[kolor])*(K4=nowa_tabela[nazwa])*(nowa_tabela[mc]=MIESIĄC(LEWY($J$1;ZNAJDŹ("'";$J$1)-1)&1))*(nowa_tabela[rok]=WARTOŚĆ(20&PRAWY($J$1;2)));0);0))

w S4
Kod:
=Q4*INDEKS(nowa_tabela[liczba];PODAJ.POZYCJĘ(1;INDEKS((J4=nowa_tabela[kolor])*(K4=nowa_tabela[nazwa])*(nowa_tabela[mc]=MIESIĄC(LEWY($J$1;ZNAJDŹ("'";$J$1)-1)&1))*(nowa_tabela[rok]=WARTOŚĆ(20&PRAWY($J$1;2)));0);0))
_________________
Pozdrawiam
Asia
ID posta: 390193 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 1669 razy
Posty: 5454
Wysłany: 27-07-2020, 10:09   

Trochę dla mnie niejasne skąd biorą się wpisy stałe po prawej stronie tabeli, np. w kolumnach J:N w arkuszu "nowe". Co decyduje o ich kolejności, dlaczego nie ma wszystkich pozycji występujących po lewej stronie?
Jeśli te dane będą spójne i unikatowe, to mając już te dodatkowe kolumny miesiąc i rok, najprościej chyba dodać dodatkowe dwa warunki na miesiąc i rok w tych kolumnach gdzie sprawdzane są warunki na kolor i nazwę.
Poprawki wprowadziłem w wierszu 4. Zmieniłem też jedną wartość lipcową, żeby było widać różnicę.

tab-wg-mca.xlsx
Pobierz Plik ściągnięto 7 raz(y) 26.14 KB

ID posta: 390195 Skopiuj do schowka
 
 
dmocha
forumowicz


Posty: 13
Wysłany: 28-07-2020, 14:47   

Asia_@, Maciej Gonet bardzo Wam dziękuję!
Muszę potestować na prawdziwych danych, które rozwiązanie będzie dla mnie wydajniejsze.

Maciej Gonet, dane o które pytasz to wynik kwerendy MS Query, dlatego to może wydawać się niezrozumiałe.
Nie mogę pokazać oryginalnych danych, dlatego na potrzeby forum, przerobiłem jeden z wyników i pokazałem jego fragment (kolumny J:N).
W oryginale wartości te zmieniają się gdy wskażę odpowiedni miesiąc w J1.
Dane te "opierają się o wytyczne", które tutaj wskazałem jako tabele czerwiec i lipiec czy też nowa_tabela.
W skrócie, jeśli użytkownik wybierze kolor i przypisaną w wierszu nazwę, to reszta z tego wiersza jest z automatu wprowadzana. Zawsze wykorzystywany jest cały wiersz tabeli z wyjątkiem czasu, bo ten jest zależny od operacji). Potem powstaje z tego kobylasty plik wynikowy, do którego sięgam kwerendą.

Mam nadzieję, że rozjaśniłem troszkę. Raz jeszcze dziękuję z pomoc.
_________________
pozdrawiam
dmocha
ID posta: 390266 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe