Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70238 Skopiuj do schowka funkcja tablicowa
Autor Wiadomość
tomason1991
Starszy Forumowicz


Posty: 47
Wysłany: 25-02-2021, 12:01   funkcja tablicowa

Witam,

Próbuje stworzyć funkcje tablicową, która porównuje dane z dwóch zakresów i jeżeli wystąpi różnica w jakimkolwiek porównaniu to wynikiem jest "1".

W załączniku przykłady do testów.
Nie rozumiem dlaczego funkcja
Kod:
{=JEŻELI(B3:H3<>I3:O3;1;0)}
działa tylko w przypadku różnicy na pierwszym porównaniu.

Proszę o pomoc.

przykład_formuła_tablicowa.xlsx
Pobierz Plik ściągnięto 19 raz(y) 9.68 KB

ID posta: 400982 Skopiuj do schowka
 
 
xfish 
Excel Expert



Wersja: Win Office 2013
Pomógł: 470 razy
Posty: 1456
Wysłany: 25-02-2021, 12:27   

Można np
Kod:
SUMA.ILOCZYNÓW((B2:H2)/(I2:O2))
jak różna niż 7 to są różnice

ewentualnie tak:
Kod:
=JEŻELI(SUMA.ILOCZYNÓW(--(B2:H2<>I2:O2));1;0)
_________________
Pozdrawiam
xFish
ID posta: 400985 Skopiuj do schowka
 
 
tomason1991
Starszy Forumowicz


Posty: 47
Wysłany: 25-02-2021, 12:58   

Kod:
=JEŻELI(SUMA.ILOCZYNÓW(--(B2:H2<>I2:O2));1;0)


Oto chodziło. Dziękuję.

A czy mógłbyś wytłumaczyć tę formułę? Szczególnie --
ID posta: 400989 Skopiuj do schowka
 
 
xfish 
Excel Expert



Wersja: Win Office 2013
Pomógł: 470 razy
Posty: 1456
Wysłany: 25-02-2021, 14:51   

<> porównuje parami elementy z tych dwóch zakresów zwracając PRAWDA gdy się różnią FAŁSZ gdy są takie same (zaznacz fragment w nawiasie i wciśnij F9 zobaczysz co widzi excel, cofnij przez Ctrl Z.)
podwójny minus zamienia PRAWDA i FAŁSZ na 1 i 0 a SUMA.ILOCZYNÓW sumuje te 0 i 1
Gdy pojawi się chociaż jedna jedynka (wynik funkcji SUMA.WARUNKÓW jest większy niż 0) funkcja JEŻELI uznaje, że warunek został spełniony i wykonuje krok wartość_jeżeli_prawda - czyli wstawia 1, w przeciwnym wypadku wstawia 0.
W zakładce Formuły masz Szacuj formułę. Tam możesz zobaczyć krok po kroku jak działa to co napisałem.
_________________
Pozdrawiam
xFish
ID posta: 400995 Skopiuj do schowka
 
 
Waldek 
Excel Expert


Wersja: Win Office 2019
Pomógł: 304 razy
Posty: 1344
Wysłany: 25-02-2021, 15:19   Re: funkcja tablicowa

tomason1991 napisał/a:
...jeżeli wystąpi różnica w jakimkolwiek porównaniu to wynikiem jest "1"...

Twoja formuła prawidłowo porównuje liczby, ale wynikiem jest 7 liczb, które są rezultatem tego porównania. By wynikiem było 1 gdy wystąpi różnica w jakimkolwiek porównaniu to musisz dodać funkcję MAX.
Kod:
=MAX(JEŻELI(B2:H2<>I2:O2;1;0))

Zobacz załącznik.

formuła_tablicowa.xlsx
Pobierz Plik ściągnięto 10 raz(y) 10.12 KB

ID posta: 401000 Skopiuj do schowka
 
 
tomason1991
Starszy Forumowicz


Posty: 47
Wysłany: 25-02-2021, 17:47   

Pięknie dziękuję :-)
ID posta: 401010 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe