Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 3047 Skopiuj do schowka Formuły tekstowe
Autor Wiadomość
Quasi 
Excel Expert


Wersja: Win Office 2010
Pomógł: 142 razy
Posty: 1067
Wysłany: 23-09-2007, 17:00   Formuły tekstowe

Hej! :-)

Mam do zrobienia pewne zadanie związane z fakturami i napotkałem na pewien problem. A mianowicie mam wartość 1 262,30, która jest wynikiem formuły
Kod:
=JEŻELI(Q24="";"";JEŻELI(Q24="ZW";0;ZAOKR(WARTOŚĆ(ZŁĄCZ.TEKSTY(O24;",";P24))*Q24;1)))
i teraz chciałbym wartośc 1 262 przenieść do kolumny "zł" a wartośc 30 przenieśc do kolumny "gr". Zrobiłem to za pomoca funkcji lewy/prawy/fragment.tekstu (wcześniej oczywiście stosując funkcję WARTOŚĆ) ale pojawia się problem gdyż Excel traktuje to 30 po przecinku jako 3 tzn. nie widzi tego zera, które jest na końcu dlatego też formuła
Kod:
=LEWY(Y24;DŁ(Y24)-3)
nie działa poprawnie gdyż Excel zamiast wartości 1262 zwraca mi 126 :-( . Prosze o poradę :).
ID posta: 15828 Skopiuj do schowka
 
 
Quasi 
Excel Expert


Wersja: Win Office 2010
Pomógł: 142 razy
Posty: 1067
Wysłany: 23-09-2007, 17:02   

Próbowałem też zastosowac Tekst jako kolumny ale niestety operuję na scalonych komórkach więc jest to niemozliwe.
_________________
http://www.swiatexcela.pl - blog nie tylko dla programistów VBA
ID posta: 15829 Skopiuj do schowka
 
 
zubel 
ExcelSpec



Pomógł: 333 razy
Posty: 566
Wysłany: 23-09-2007, 17:12   

a nie możesz
dla złotych
Kod:

=ZAOKR.DO.CAŁK(A1)


a dls groszy
Kod:

=MOD(A1;ZAOKR.DO.CAŁK(A1))
_________________
zubel
ID posta: 15831 Skopiuj do schowka
 
 
Quasi 
Excel Expert


Wersja: Win Office 2010
Pomógł: 142 razy
Posty: 1067
Wysłany: 23-09-2007, 17:20   

zubel, dzieki wielkie !!! :-) zupełnie zapomniałem o funkcji ZAOKR.DO.CAŁK. Działa rewelacyjnie tylko w drugim przypadku trzeba jeszcze pomnożyć wartość * 100 ale to paździerz. Szacuneczek :-) ))))).
_________________
http://www.swiatexcela.pl - blog nie tylko dla programistów VBA
ID posta: 15832 Skopiuj do schowka
 
 
Quasi 
Excel Expert


Wersja: Win Office 2010
Pomógł: 142 razy
Posty: 1067
Wysłany: 23-09-2007, 22:19   

Jeszcze jedna sprawa - potrzebny mi jest format komórki dla wartości groszowych tzn. chciałbym żeby zamiast np. 8 było 08 gdyż Excel potem interpretuje mi ta wartośc jako 80gr i wychodza błędne wyniki przy obliczaniu różnicy :-) . Z góry dziękuję :-) .
_________________
http://www.swiatexcela.pl - blog nie tylko dla programistów VBA
ID posta: 15838 Skopiuj do schowka
 
 
zubel 
ExcelSpec



Pomógł: 333 razy
Posty: 566
Wysłany: 23-09-2007, 22:25   

ale wtedy będzie to jako tekst

np:
Kod:

=TEKST(MOD(A1;ZAOKR.DO.CAŁK(A1))*100;"00")
_________________
zubel
ID posta: 15839 Skopiuj do schowka
 
 
Quasi 
Excel Expert


Wersja: Win Office 2010
Pomógł: 142 razy
Posty: 1067
Wysłany: 23-09-2007, 22:37   

Nie może tak być :-) - to musi być albo wartość liczbowa albo format dostępny z pozycji Formatuj komórki ... :-)
_________________
http://www.swiatexcela.pl - blog nie tylko dla programistów VBA
ID posta: 15840 Skopiuj do schowka
 
 
zubel 
ExcelSpec



Pomógł: 333 razy
Posty: 566
Wysłany: 23-09-2007, 22:41   

u mnie zadziałał format niestandardowy
wpisałem

Kod:

00;-00;00
_________________
zubel
ID posta: 15841 Skopiuj do schowka
 
 
Quasi 
Excel Expert


Wersja: Win Office 2010
Pomógł: 142 razy
Posty: 1067
Wysłany: 23-09-2007, 22:59   

:danke :clap :happy
_________________
http://www.swiatexcela.pl - blog nie tylko dla programistów VBA
ID posta: 15843 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe