Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63716 Skopiuj do schowka Formuła jeżeli
Autor Wiadomość
cezaryfcb89 
forumowicz


Posty: 21
Wysłany: 07-01-2019, 19:19   Formuła jeżeli

Plik w załączniku mam pytanie co do zadania jest ono trochę z matematyki mam użyć formułę do obliczenia takich założeń
I wersja
jeżeli x jest mniejszy 85%>x = 0 Dopłaty
85% weryfikacji = 80% Dopłaty
95% weryfikacji = 100% Dopłaty
x>=99% weryfikacji 120%

muszę obliczyć za pomocą funkcji przedział procentowy między weryfikacjami w załączniku zrobiłem formułę ale coś tam nie gra, w załączniku opisałem założenia, z góry dzięki za odpowiedz.

cezaryfcb89 w dniu: 2019-01-07, 19:23 napisał/a:
załącznik

edycja Zbiniek:
Proszę korzystać z opcji edytowania wypowiedzi – przycisk „edytuj”. Opcja jest dostępna bodajże przez 30 minut od momentu wysłania wypowiedzi.


Zeszyt11.xlsx
Pobierz Plik ściągnięto 6 raz(y) 11.32 KB

  
ID posta: 359922 Skopiuj do schowka
 
 
cezaryfcb89 
forumowicz


Posty: 21
Wysłany: 07-01-2019, 20:52   

Zrobiłem I wersję trochę zmieniając formułę kolumna D28 w dół
Kod:
=JEŻELI(B28/A28=0,85;80%;JEŻELI(B28/A28=0,95;100%;JEŻELI(B28/A28>=0,99;120%;JEŻELI(B28/A28>0,95;(((B28/A28)-0,95)*5)+1;JEŻELI(B28/A28>0,85;(((B28/A28)-0,85)*2)+0,8;0)))))

cezaryfcb89 w dniu: 2019-01-07, 21:02 napisał/a:
Taka jest moja wersja II wariantu
Kod:
=JEŻELI(J28/I28=0,85;80%;JEŻELI(J28/I28=0,95;100%;JEŻELI(J28/I28=1;120%;JEŻELI(J28/I28>0,95;(((J28/I28)-0,95)*4)+1;JEŻELI(J28/I28>0,85;(((J28/I28)-0,85)*2)+0,8;0)))))
mam pytanie czy może ktoś ma inny pomysł Wersje finalne są w kolumnie D28 I wersja, L28 II wersja może ktoś wie czy to jest OK

edycja Zbiniek:
1. Proszę korzystać z opcji edytowania wypowiedzi – przycisk „edytuj”. Opcja jest dostępna bodajże przez 30 minut od momentu wysłania wypowiedzi.
2. Przy wpisywaniu kodów makr lub formuł proszę używać znaczniki [code] (zgodnie z pkt. 3.1 Regulaminu naszego forum).


Zeszyt11b.xlsx
Pobierz Plik ściągnięto 2 raz(y) 13.81 KB

Kopia Zeszyt11bc.xlsx
Pobierz Plik ściągnięto 1 raz(y) 14.62 KB

  
ID posta: 359931 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1193 razy
Posty: 4107
Wysłany: 07-01-2019, 22:37   

cezaryfcb89 napisał/a:
Zrobiłem I wersję trochę zmieniając formułę kolumna D28 w dół

=JEŻELI(B28/A28=0,85;80%;JEŻELI(B28/A28=0,95;100%;JEŻELI(B28/A28>=0,99;120%;JEŻELI(B28/A28>0,95;(((B28/A28)-0,95)*5)+1;JEŻELI(B28/A28>0,85;(((B28/A28)-0,85)*2)+0,8;0)))))

Moim zdaniem masz niepoprawne wyniki w D49:D51
Moja I wersja
D3
Kod:

=JEŻELI(C3<0,85;0;JEŻELI(C3<0,95;0,8+2*(C3-0,85);JEŻELI(C3<0,99;1+5*(C3-0,95);1,2)))


II wersja podobnie
ID posta: 359943 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 1125 razy
Posty: 3382
Wysłany: 07-01-2019, 22:38   

Przetestuj formułę w 'E28' (dla porównania) z kopią w dół.
Kod:
=JEŻELI(B28/A28>=0,99;120%;JEŻELI(B28/A28>0,95;5*((B28/A28)-0,95)+1;JEŻELI(B28/A28=0,95;100%;JEŻELI(B28/A28>0,85;2*((B28/A28)-0,85)+0,8;JEŻELI(B28/A28=0,85;80%;0)))))
Pozdrawiam.
ID posta: 359944 Skopiuj do schowka
 
 
KOKOSEK
świeżak


Posty: 9
Wysłany: 15-01-2019, 00:04   

Zawartość D3 dla pliku z pierwszego postu:

Kod:
=WYSZUKAJ.PIONOWO(B3/A3,{0,0;0.85,0.8;0.95,1;1,1.2},2,1)


i leć z tym w dół.

p.s. mam parametry 'z przecinkami' zmień sobie na 'sredniki'
  
ID posta: 360460 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1193 razy
Posty: 4107
Wysłany: 15-01-2019, 02:34   

KOKOSEK napisał/a:
Zawartość D3 dla pliku z pierwszego postu:

Kod:
=WYSZUKAJ.PIONOWO(B3/A3,{0,0;0.85,0.8;0.95,1;1,1.2},2,1)



Chyba nie czytałeś uważnie. ;-)
W przedziałach (0,85;0,95) oraz (0,95;0,99) wartości mają być obliczone proporcją. Czyli np. B3/A3 = 0,98 to wynik = 115%, a Twoja formuła zwraca 100%.
ID posta: 360467 Skopiuj do schowka
 
 
KOKOSEK
świeżak


Posty: 9
Wysłany: 15-01-2019, 17:41   

Niestety Excel wersja EN

Do D3:
Kod:
=IF(C3>=0.85,MIN(1.2,0.8+MAX(0,((C3-0.85)*2))+MAX(0,((C3-0.95)*3))),0)
ID posta: 360516 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe