Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70087 Skopiuj do schowka Formuła INDEKS - wyszukiwanie 3 warunki
Autor Wiadomość
lekkir 
Forumowicz


Wersja: Win Office 2013
Posty: 21
Wysłany: 08-02-2021, 13:00   Formuła INDEKS - wyszukiwanie 3 warunki

Witam,

Proszę o pomoc z formułą INDEKS. Potrzebuje stworzyć taką formułę która wyszuka odpowiednią wartość w tabeli na podstawie dwóch wartości w wierszach oraz jednej wartości w kolumnie. Dla 2 warunków (jednej w wierszu i jeden w kolumnie) nie mam problemu ale przy 3 warunkach coś mnie paraliżuje i nie daję rady. A może trzeba innej formuły?

Załączony plik powie więcej niż tysiące słów o co mi chodzi... :-D

Wyszukaj.xlsx
Przykładowy plik
Pobierz Plik ściągnięto 13 raz(y) 10.53 KB

ID posta: 399965 Skopiuj do schowka
 
 
Asia_@. 
Excel Expert


Pomogła: 2743 razy
Posty: 4600
Wysłany: 08-02-2021, 13:13   

tablicowa (należy zatwierdzić klawiszami Ctrl+Shift+Enter)
Kod:
=INDEKS(B$3:J$5;PODAJ.POZYCJĘ(D16;A$3:A$5;0);PODAJ.POZYCJĘ(B16&C16;B$1:J$1&B$2:J$2;0))

albo
Kod:
=SUMA.ILOCZYNÓW((A$3:A$5=D16)*(B$1:J$1=B16)*(B$2:J$2=C16)*(B$3:J$5))
_________________
Pozdrawiam
Asia
ID posta: 399966 Skopiuj do schowka
 
 
lekkir 
Forumowicz


Wersja: Win Office 2013
Posty: 21
Wysłany: 08-02-2021, 13:45   

Działa elegancko! i pomyśleć że byłem tak blisko :)

Pozdrawiam
ID posta: 399969 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe