Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 70225 Skopiuj do schowka Formuła dodająca numer do istniejącej wartości
Autor Wiadomość
stingtanner
ExcelGaduła 500+


Wersja: Win Office 2013
Pomógł: 6 razy
Posty: 508
Wysłany: 23-02-2021, 14:40   Formuła dodająca numer do istniejącej wartości

Witajcie

W kolumnie "N" mam kawałek treści, która obrazuje co chcę mieć w kolumnie "I"

W kolumnie "N" mam numery, które powstają w wyniku takiej formuły:
Kod:
= WENNFEHLER(INDEX('Bestelldaten 2020'!$AA$1:$AA$6924;VERGLEICH(1;(VERKETTEN($G$9;"-";A24)='Bestelldaten 2020'!$C$1:$C$6924)*(ISTZAHL('Bestelldaten 2020'!$V$1:$V$6924));0));INDEX('Bestelldaten 2020'!$AA$1:$AA$6924;VERGLEICH(1;(VERKETTEN($G$9;"-";A24)='Bestelldaten 2020'!$C$1:$C$6924)*(ISTZAHL('Bestelldaten 2020'!$T$1:$T$6924));0)))

Ale to chyba mało istotne :)

Chciał bym dodać do tej formuły numer LP ale w postaci 10, 20, 30 dla każdego unikatowego numeru. Tak jak w przykładzie kolumny "I"

Dodam iż niestety musi to być formuła, nie chcę dokładać tu makra które spowolniło by arkusz jeszcze bardziej.

formula_numery.xlsm
Pobierz Plik ściągnięto 4 raz(y) 13.86 KB

ID posta: 400892 Skopiuj do schowka
 
 
Czeslaw
ExcelSpec


Pomógł: 206 razy
Posty: 706
Wysłany: 23-02-2021, 15:05   

Formula
Kod:
=I24&-&COUNTIF(I$24:I24;I24)*10


Copy of formula_numery.xlsm
Pobierz Plik ściągnięto 5 raz(y) 9.88 KB

ID posta: 400895 Skopiuj do schowka
 
 
stingtanner
ExcelGaduła 500+


Wersja: Win Office 2013
Pomógł: 6 razy
Posty: 508
Wysłany: 23-02-2021, 15:54   

Czeslaw,
Dziękuję
Działa jak trzeba.
ID posta: 400907 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe