Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 68553 Skopiuj do schowka formuła dla kilku warunków
Autor Wiadomość
szczur4
Starszy Forumowicz


Wersja: Win Office 365
Posty: 29
Wysłany: 20-07-2020, 14:37   formuła dla kilku warunków

Cześć,
potrzebuje formułę, która w ostatniej kolumnie wskaże mi czy wszystkie kryteria zostały spełnione.Dane sortuje po dacie (od nastarszej) i Nr. Potrzebuje znaleźć sprawy gdzie Nr jest ten sam i dla tego numeru wystąpiło TAK w kryterium 1, później wystąpiło zdarzenie Wpłata dla tego samego Nr, a następnie w kryterium 3 wystąpiło Potwierdzenie.

Jeżeli w kolumnie Nr byłyby tylko 2 takie same wartości to kod byłby prosty
Kod:
=JEŻELI(ORAZ(A3=A2;C2="TAK";C3="WPŁATA";D3="Potwierdzenie");"TAK";"NIE")

natomiast mogą wystąpić więcej razy i tutaj pojawia się problem.

Przykład3.xlsx
Pobierz Plik ściągnięto 9 raz(y) 77.75 KB

ID posta: 389912 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 662 razy
Posty: 3481
Wysłany: 20-07-2020, 15:38   

A nie wystarczy tak? (Zał.)
.

Kopia Przykład3.xlsx
Pobierz Plik ściągnięto 10 raz(y) 77.98 KB

_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
Chcesz precyzyjną odpowiedź - zadaj precyzyjne pytanie.
ID posta: 389920 Skopiuj do schowka
 
 
szczur4
Starszy Forumowicz


Wersja: Win Office 365
Posty: 29
Wysłany: 20-07-2020, 17:30   

akurat dla tych danych z przykładu wystarczy bo dla każdego potwierdzenia są spełnione pozostałe 2 warunki.
Problem z tym, że nie zawsze tak będzie
ID posta: 389936 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe