Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 55584 Skopiuj do schowka (Formatowanie warunkowe) Wskaż duplikaty nie działa poprawni
Autor Wiadomość
shyha
Fan Excela


Posty: 65
  Wysłany: 11-01-2017, 17:55   (Formatowanie warunkowe) Wskaż duplikaty nie działa poprawni

Witam,
Dlaczego dla poniższych wartości komórek "formatowanie warunkowe - wskaż duplikaty" działa niepoprawnie. Plik w załączniku.
Można to jakoś naprawić?
800561026312061550008505
408450074936861990098437
408450074996262040015300
408450074996262040015298
408450074996262040015304
408450074989462030059687
408450074989462030059686

Formatowanie warunkowe duplikaty.xlsx
Plik z przykładem
Pobierz Plik ściągnięto 13 raz(y) 9.25 KB

ID posta: 312655 Skopiuj do schowka
 
 
MS_Analyst 
ExcelSpec


Pomógł: 109 razy
Posty: 435
Wysłany: 11-01-2017, 19:08   

Witaj.
Problem można rozwiązać zamieniając Twoje liczby na ciąg tekstowy np. dodając na początku apostrof " ' " funkcją ZŁĄCZ.TEKSTY. Wtedy formatowanie warunkowe zadziała poprawnie, bo będzie szukało podobnego ciągu tekstowego. Niestety przy liczbach większych od 15 znaków excel zapamiętuje 15 cyfr, a w resztę wstawia 0, dlatego Twoje liczby zaznaczone są kolorem.
Moje rozwiązanie w załączniku.

Pozdrawiam,
Piotrek

Formatowanie warunkowe duplikaty-1.xlsx
Pobierz Plik ściągnięto 6 raz(y) 9.59 KB

ID posta: 312657 Skopiuj do schowka
 
 
shyha
Fan Excela


Posty: 65
Wysłany: 12-01-2017, 10:29   

Dzięki. Domyślałem się, że Excel sobie "obcina" te dane.
Problem w tym, że kolumna uzupełniana jest przez skaner. Czy da się skonfigurować kolumnę w VBA, aby z automatu nadawała ten prefiks formatujący na tekst?
ID posta: 312673 Skopiuj do schowka
 
 
Maciej Gonet
Excel Expert


Pomógł: 773 razy
Posty: 2621
Wysłany: 12-01-2017, 12:12   

Jako regułę formatowania warunkowego zastosuj sobie formułę:
Kod:
=SUMA(($A$1:$A$27=A1)*1)*(A1<>"")>1


Formatowanie warunkowe duplikaty.xlsx
Pobierz Plik ściągnięto 9 raz(y) 10.18 KB

ID posta: 312689 Skopiuj do schowka
 
 
shyha
Fan Excela


Posty: 65
Wysłany: 12-01-2017, 12:56   

Dzięki :) O to chodziło! Idealnie.
ID posta: 312692 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum


Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.