Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 63752 Skopiuj do schowka Formatowanie warunkowe kilku wierszy na podstawie jednego
Autor Wiadomość
mancia14 
Exceloholic


Pomógł: 2 razy
Posty: 169
Wysłany: 09-01-2019, 18:16   Formatowanie warunkowe kilku wierszy na podstawie jednego

Cześć!

Chciałbym uzyskać pewien efekt. Chciałbym, aby formatowanie warunkowe sprawdzało warunek dla wszystkich wartości w kolumnie A:A czy któraś z nich równa się DZIŚ().
Jeżeli napotka na spełnienie zasady, wtedy pogrubi czcionkę na trzech wierszach w dół łącznie z wierszem, w którym znajduje się spełniony warunek.

W załączniku plik z oczekiwanym wynikiem.

Czy to możliwe do uzyskania?

przykład.xlsx
Pobierz Plik ściągnięto 12 raz(y) 9.15 KB

ID posta: 360112 Skopiuj do schowka
 
 
BrunO 
ExcelSpec



Pomógł: 125 razy
Posty: 541
Wysłany: 09-01-2019, 18:34   

Reguła oparta na formule
Kod:
=LUB($A1=DZIŚ();$A2=DZIŚ();$A3=DZIŚ())

z tym, że musiałem na górze dodać 2 puste wiersze, bo dla wiersza 1 nie dałoby się odwołac do wiersza -1 i -2

przykład2.xlsx
Pobierz Plik ściągnięto 9 raz(y) 9.97 KB

ID posta: 360115 Skopiuj do schowka
 
 
mancia14 
Exceloholic


Pomógł: 2 razy
Posty: 169
Wysłany: 09-01-2019, 19:03   

Działa! Dziękuję za natychmiastową odpowiedź BrunO.
ID posta: 360119 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Pomógł: 257 razy
Posty: 1395
Wysłany: 09-01-2019, 19:06   

Kod:
Option Explicit

Sub b()
Dim i&, d&, j As Integer, k&

Cells.Font.Bold = False
d = Cells(Rows.Count, "A").End(xlUp).Row

For i = 1 To d
    If Cells(i, 1).Value = Date Then
        For j = i To i + 2
            For k = 1 To 5
                Cells(j, k).Font.Bold = True
            Next k
        Next j
    End If
Next i

End Sub
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
I dbajmy - proszę - o poprawną polszczyznę.
ID posta: 360120 Skopiuj do schowka
 
 
apollo
ExcelSpec


Pomógł: 1230 razy
Posty: 4257
Wysłany: 09-01-2019, 22:41   

Podałem swoje rozwiązanie. Dlaczego pan umiejead skasował moje rozwiązanie?

Proszę podać powód usunięcia mojego postu.

Napisałem kilka postów w tym wątku. Skoro ten kto ma władzę skasował to nic nie mogę zrobić. Ale chodzi mi tylko o ten post z rozwiązaniem. Czy ten post z rozwiązaniem narusza w jakiś sposób regulamin? Jeśli tak to proszę podać konkretnie, jaki punkt regulamin narusza.

Szczyt bezczelności. To, że jesteś moderatorem, nie znaczy, że możesz skasować wszystko bez powodu. Rozwiązanie podałem dla innych, nawet nie koniecznie dla pytającego, nie dla ciebie, panie umiejead.

Podaję jeszcze raz mój skasowany post. Niech inni ocenią, czy ten post narusza regulamin, i czy pan umiejead ma prawo skasować ten post.

1. Jeśli dane są od wiersza 1 tak, jak w dołączonym pliku, to wybierz A1:E100 (zmień na
odpowiednią) -> FW -> użyj formuły -> wklej poniższą formułę -> wybierz czcionkę pogrubioną
Kod:

=LICZ.JEŻELI(PRZESUNIĘCIE($A1;MAX(-2;1-WIERSZ(A1));;MIN(3;WIERSZ

(A1)));DZIŚ())


2. Jeśli dane są od wiersza 3, 4, itd. to formuła
Kod:

=LICZ.JEŻELI(PRZESUNIĘCIE($A1;-2;;3);DZIŚ())


przykład.xlsx
Pobierz Plik ściągnięto 7 raz(y) 10.33 KB

ID posta: 360147 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe