Excel Forum - Porady, Pomoc,  Excel Help, Excel FAQ Strona Główna
 FAQ  RegulaminRegulamin  Szukaj   Użytkownicy   Grupy   Rejestracja   Profil   Twoje wiadomości   Zaloguj 


Poprzedni temat «» Następny temat
ID tematu: 64069 Skopiuj do schowka Formatowanie komórki - dodanie zera przed liczbą
Autor Wiadomość
polaczek91 
Fan Excela


Posty: 79
Wysłany: 07-02-2019, 18:57   Formatowanie komórki - dodanie zera przed liczbą

Witam, mam następujący problem: Posiadam dużą ilość danych, która ma być przedstawiona w formie daty, niestety niektóre wartości nie posiadają 0 na początku, w związku z czym Excel źle odczytuje format. Moje pytanie brzmi czy można jakoś sformatować właściwość komórki, aby automatycznie dodała 0 na początku i aby formuła widziała to?

Próbowałem poprzez niestandardowe formatowanie, zero sztucznie pokazuje, natomiast formuła nie widzi go, przez co pokazuje złe daty (kolumna B), w kolumnie C dałem prostą funkcję jeżeli i długość, dzięki czemu efekt jest osiągany, aczkolwiek chciałbym uzyskać dany efekty poprzez widoczne dla formuły zero, w kolejnej kolumnie (D) użyłem tekst jako kolumny i niestety taka sama sytuacja. Z góry dzięki za pomoc.

tekst.xlsx
Pobierz Plik ściągnięto 16 raz(y) 9.64 KB

ID posta: 362152 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 278 razy
Posty: 1521
Wysłany: 07-02-2019, 19:38   

A 1 styczeń 2019? Czy to nie będzie czasem 1119?
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
I dbajmy - proszę - o poprawną polszczyznę.
ID posta: 362156 Skopiuj do schowka
 
 
polaczek91 
Fan Excela


Posty: 79
Wysłany: 07-02-2019, 19:48   

10119 będzie 1 stycznia 2019 roku.


EDIT

Plik z którego pobierane są daty uwzględnia zera w środku przy miesiącach, natomiast przy dniu w momencie kiedy jest od 1 do 9 nie dodaje zera.
ID posta: 362157 Skopiuj do schowka
 
 
Waldek 
ExcelSpec


Pomógł: 121 razy
Posty: 579
Wysłany: 07-02-2019, 19:59   Re: Formatowanie komórki - dodanie zera przed liczbą

polaczek91 napisał/a:
...w kolumnie C dałem prostą funkcję jeżeli i długość...

Ja dodałem długość w komórce B2 i wygląda na to, że działa.
Kod:
=DATA(2000+PRAWY(A2;2);FRAGMENT.TEKSTU(A2;3;2);LEWY(A2;DŁ(A2)-4))
ID posta: 362159 Skopiuj do schowka
 
 
polaczek91 
Fan Excela


Posty: 79
Wysłany: 07-02-2019, 20:01   

Nie działa niestety, spójrz na wiersz 19. Excel w funkcji Fragment.Tekstu nie widzi 6 znaków, a 5.
ID posta: 362160 Skopiuj do schowka
 
 
Waldek 
ExcelSpec


Pomógł: 121 razy
Posty: 579
Wysłany: 07-02-2019, 20:11   

Bo trzeba drugi raz wstawić . Wstaw w B2:
Kod:
=DATA(2000+PRAWY(A2;2);FRAGMENT.TEKSTU(A2;DŁ(A2)-3;2);LEWY(A2;DŁ(A2)-4))
ID posta: 362161 Skopiuj do schowka
 
 
umiejead 
Excel Expert


Wersja: Win Office 2013
Pomógł: 278 razy
Posty: 1521
Wysłany: 07-02-2019, 20:12   

Kol. pomocnicza:
Kod:
=JEŻELI(DŁ($A2)<6;"0"&$A2;$A2)
_________________
.
Jak poprawnie opisać problem: http://www.excelforum.pl/...ika-vt59262.htm
I dbajmy - proszę - o poprawną polszczyznę.
ID posta: 362162 Skopiuj do schowka
 
 
polaczek91 
Fan Excela


Posty: 79
Wysłany: 07-02-2019, 20:34   

Dziękuję!
ID posta: 362163 Skopiuj do schowka
 
 
kuma 
Excel Expert


Pomógł: 1178 razy
Posty: 3518
Wysłany: 07-02-2019, 20:38   

Można też tak.
W pomocniczej kolumnie i kopia w dół. W kol. A "surowe dane"
Kod:
=TEKST(A2;"000000")
Zaznaczyć zakres z formułami, wykonaj Ctrl+C i wklej, w to samo miejsce, ale tylko wartości.
Teraz 'Tekst jako kolumny' -> Stała szerokość-> Dalej-> Dalej ->Data i opcja ->DMR -> Zakończ.
Pozdrawiam.
ID posta: 362164 Skopiuj do schowka
 
 
Maciej Gonet 
Excel Expert


Wersja: Win Office 2016
Pomógł: 1248 razy
Posty: 4291
Wysłany: 08-02-2019, 11:50   

Jeśli kolejność elementów daty tzn. dmmrr jest zgodna z ustawieniem systemowym w używanym komputerze, to wystarczy tak:
Kod:
=--TEKST(A2;"00-00-00")
Użyty tu separator też musi być zgodny z ustawionym w systemie. Format komórki wynikowej należy ustawić ręcznie.

tekst_daty.xlsx
Pobierz Plik ściągnięto 12 raz(y) 10.36 KB

ID posta: 362204 Skopiuj do schowka
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme xandgreen created by spleen& Programosy modified v0.3 by warna
Opieka techniczna www.marketingNET.pl

Archiwum

Strona używa plików cookies.

Kliknij tutaj, żeby dowiedzieć się jaki jest cel używania cookies oraz jak zmienić ustawienia cookie w przeglądarce.
Korzystając ze strony użytkownik wyraża zgodę na używanie plików cookies, zgodnie z bieżącymi ustawieniami przeglądarki.
Sprawdź, w jaki sposób przetwarzamy dane osobowe